Bug 138798 - JFS + SELinux FC3 Installer Issue
Summary: JFS + SELinux FC3 Installer Issue
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 08:50 UTC by Jeff Means
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 21:27:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Means 2004-11-11 08:50:10 UTC
Description of problem:
Issue with JFS install:  When installing to a device (AKA: Hard Disk)
freshly formatted with FC3 JFS installer hangs due to inability to
write to device.  Caused by conflicts with SELinux enabled durring
install and the JFS format not properly labeling the device so SELinux
blocks write access to said device.

Version-Release number of selected component (if applicable):
FC3-installer

How reproducible:
All three times I tried to install to a JFS formatted partition on
three seperate platforms.

Steps to Reproduce:
1. Use Disk Druid to partition /
2. Mark partition / to be formatted with JFS
3. Continue with install
  
Actual results:
Nothing gets installed and user recieves a fatal device unwriteable /
unready error and install aborts.

Expected results:
Installer installs to drive, and loads FC3 on the drive

Additional info:

Comment 1 Jeremy Katz 2004-11-11 18:57:46 UTC
JFS isn't supported.  You'll need to add selinux=0 to your boot
command line.


Note You need to log in before you can comment on or make changes to this bug.