Bug 138809 - Gphoto does not work as a normal user
Gphoto does not work as a normal user
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 05:51 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 06:29:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-11-11 05:51:17 EST
Description of problem:
when gphoto is run as a normal user I get

An error occurred in the io-library ('Could not claim the USB
device'): Could not claim interface 0 (Operation not permitted). Make
sure no other program or kernel module (such as sdc2xx, stv680,
spca50x) is using the device and you have read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***

As root everything works

Version-Release number of selected component (if applicable):
Comment 1 Tim Waugh 2004-11-11 06:51:19 EST
And if you switch the camera off, and then on?
Comment 2 Need Real Name 2004-11-12 03:53:18 EST
same result
Comment 3 Linus Walleij 2004-11-12 05:43:43 EST
This problem is in /etc/hotplug/usb/usbcam

The script assumes the name of the current desktop user will be
available in a lock file in /var/lock/console/console.lock, but the
username nowadays appear as a separate file beside the lockfile. E.g.
when the user foo logs in, a file named /var/lock/console/foo appears.

There needs to be written a patch...
Comment 4 Tim Waugh 2004-11-12 06:16:52 EST
Please confirm the version of gphoto2 you are using with 'rpm -q gphoto2'.

This should have been fixed as a result of bug #130755.
Comment 5 Need Real Name 2004-11-12 06:39:16 EST
2.4.1.7

This works 

[root@datacc mike]# /usr/lib/libgphoto2/print-usb-usermap |grep -A1
PDR-M65>>/etc/hotplug/usb.usermap

(even import dialogue comes up and all works)


Comment 6 Tim Waugh 2004-11-12 06:55:10 EST
The %post scriptlet of the package should have already done this:

postinstall scriptlet (using /bin/sh):
# add supported cameras to /etc/hotplug/usb.usermap
grep -v '^usbcam' /etc/hotplug/usb.usermap > /etc/hotplug/usb.usermap.tmp
/usr/lib/libgphoto2/print-usb-usermap >> /etc/hotplug/usb.usermap.tmp
mv /etc/hotplug/usb.usermap.tmp /etc/hotplug/usb.usermap
# register libraries
/sbin/ldconfig

Please check the /root/install.log file that anaconda generated during
installation to see if there were any errors when installing the gphoto2 package.
Comment 7 Tim Waugh 2004-11-12 06:56:41 EST
Also: are there any other 'usbcam' entries in usb.usermap other than the ones
you have added?
Comment 8 Need Real Name 2004-11-12 07:31:44 EST
yeah there were 

I think I know what the issue is now.

I have to use a more recent version of libgphoto to support my camera
so this line isn't added
Comment 9 Need Real Name 2004-11-12 07:32:49 EST
Just as a suggestion would it be an idea to split gphoto and libgphoto
into seperate RPM's
Comment 10 Tim Waugh 2004-11-12 08:26:38 EST
A more recent version of libgphoto2?  We ship 2.1.4, and according to
http://sourceforge.net/projects/gphoto that is the more recent.

Do you mean CVS?
Comment 11 Tim Waugh 2004-12-10 06:29:04 EST
No feedback; closing.

Note You need to log in before you can comment on or make changes to this bug.