Bug 138816 - Bringing up the network with the b44 module hangs the PC when used for Broadcom bc4401 card
Bringing up the network with the b44 module hangs the PC when used for Broadc...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 07:13 EST by Peleonk
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 14:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peleonk 2004-11-11 07:13:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
A fresh install of Fedora Core 3 is made on a Dell Inspiron 8600c
laptop with a network card broadcom bcm4401.

The card is identified during installation and the module b44 asigned
to device eth0 via:

alias eth0 b44

in /etc/modprobe.conf

When the network is brought up, the systen hungs, with a process

ksoftirqd/0

using 99% of the CPU.


After a while, the network interface says (via system-control-network)
that the network is up, but in fact it is not working, with a message

Link is down

in dmesg.
The process ksoftirqd/0 continues using 99% of the CPU until rebooting

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Do a fresh install of FC 3
2. The system hungs when bringing up the network

or

1. Do a fresh install of FC 3
2. Choose to not bring up the network on boot
3. Use system-control-network to bring up eth0
    

Actual Results:  The system hungs

Expected Results:  The network card works

Additional info:
Comment 1 Need Real Name 2004-11-23 12:06:37 EST
I have similar symptoms on a Dell 5150 except the symptoms did not 
start untill I upgraded memory from 1 to 2 G.

rob@fatkat.com
Comment 2 Sergio Pascual 2004-12-03 13:56:50 EST
The network card works in the same system (Dell Inspiron 8600c) with
SuSE linux 9.0 (it has a kernel 2.4.21) but hangs as shown above when
using FC3
Comment 3 Josh Mattila 2005-01-23 21:46:45 EST
I get the same problem.  I have a broadcom integrated network card of
the same model and oddly enough I just upgraded to 1.5 gigs of ram
recently.  Is there a possible correlation?
Comment 4 Dave Jones 2005-01-23 21:56:58 EST
is this any better with the 2.6.10 based update ?
Comment 5 Josh Mattila 2005-01-23 22:11:59 EST
I haven't tried that yet, I am going to try to take out a 512 stick of
memory before I go about updating the kernel.
Comment 6 Peleonk 2005-01-24 07:04:11 EST
I am the original reporter, and I would like to specify that my
system has also a large RAM: 2Gb. Perhaps this is he key to solve
the problem.
Comment 7 Josh Mattila 2005-01-25 00:40:32 EST
I have tried compiling and installing the 2.6.10 kernel and was
surprised to find that the b44 driver wasn't even installed when I
booted into it.  I haven't looked into reinstalling the driver, but
obviously it wouldn't work. ;)

I will try to take out a stick of memory next (bringing my total
memory down to 1024 mb).
Comment 8 Josh Mattila 2005-01-27 23:39:04 EST
I can confirm that installing the 2.6.10 kernel DOES fix the problem.
 The driver needs to be reinstalled (at least for me), but once it
was, everything worked very smoothly (even with the large amount of
memory installed).  Hopefully this bug will be fixed in the Fedora
Core 4 release (that is, if it was a bug associated with that
particular release). =)

If anyone else would like to test it, you can, but as far as I am
concerned, this issue is resolved.
Comment 9 Peleonk 2005-02-11 17:56:51 EST
I am the original reporter. I confirm that installing FC3 and upgrading the
kernel 2.6.10 DOES FIX the problem. No matter the amount of RAM.
The issue is resolved.
Comment 10 Warren Togami 2005-02-11 20:04:39 EST
That is probably because the latest FC3 kernels have turned off 4G/4G memory
split, which exposed this bug in the b44 driver.  The driver itself still needs
fixing, but this is an upstream issue?
Comment 11 Dave Jones 2005-07-15 13:57:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Peleonk 2005-07-18 09:33:11 EDT
I have updated my FC3 from kernel-2.6.11-1.35_FC3 to kernel-2.6.12-1.1372_FC3.
The PC now does not hung, but the network does not work. The update DOES NOT FIX
the problem. Please turn off 4G/4G memory split again.
Thanks in any case.
Comment 13 Dave Jones 2005-07-29 20:54:52 EDT
There is no 4G/4G memory split in Fedora kernels since about 6 months ago.
Comment 14 John W. Linville 2005-08-01 10:02:36 EDT
Do you get any error messages related to b44? 
Do tcpdump or ethereal show outgoing frames? 
Do the above tools running on a different host on the network show incoming 
frames? 
If either of the last two are true, then please attach some sample output. 
 
Can you elaborate on the problem?  "The network does not work" is not overly 
useful by itself. :-)  Thanks! 
Comment 15 John W. Linville 2005-09-16 14:44:56 EDT
Closed due to lack of response.  Please re-open when the requested information 
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.