Bug 138832 - Enable OProfile profile support for UP i686 kernel
Summary: Enable OProfile profile support for UP i686 kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
: 144200 (view as bug list)
Depends On:
Blocks: 144200
TreeView+ depends on / blocked
 
Reported: 2004-11-11 14:41 UTC by William Cohen
Modified: 2015-01-04 22:11 UTC (History)
5 users (show)

Fixed In Version: 2.6.9-6.31.EL
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 14:55:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to enable oprofile on UP kernel (263 bytes, patch)
2004-11-11 14:44 UTC, William Cohen
no flags Details | Diff

Description William Cohen 2004-11-11 14:41:38 UTC
OProfile driver in the 2.6 kernel works in UP kernels; this was not
the case with OProfile driver in the 2.4 kernels. The 2.6 driver has
fallback to a timer interrupt mechanism that will work in the UP kernels.

Enabling this will avoid having to tell people to install SMP kernels
to do performance measurements.  It will also allow people to do
performance characterization and tuning on UP machine machines such as
laptops, where improved performance can reduce power consumption and
increased battery life.

Comment 1 William Cohen 2004-11-11 14:44:15 UTC
Created attachment 106503 [details]
patch to enable oprofile on UP kernel

A minimal enabling so that the oprofile timer interrupt mechanism is available
to collect data on the UP kernel.

Comment 2 Suzanne Hillman 2004-11-12 16:47:13 UTC
Internal RFE bug #139031 entered; will be considered for future releases.

Comment 3 Keve Gabbert 2005-01-06 17:38:15 UTC
*** Bug 144200 has been marked as a duplicate of this bug. ***

Comment 4 Geoff Gustafson 2005-03-23 22:12:33 UTC
This change...

+CONFIG_PROFILING=y
+CONFIG_OPROFILE=m

is present in kernel-2.6.9-i686.config, in kernel-2.6.9-6.31.EL.

Is this all that is needed? Done for U1?


Comment 5 Dave Jones 2005-03-24 00:20:21 UTC
should be, though I've personally not tested the functionality.


Comment 6 William Cohen 2005-03-24 14:55:15 UTC
I installed kernel-2.6.9-6.31.EL.i686.rpm, and verified that it worked as
expected on a UP Athlon machine.

$ opreport --long-filenames
CPU: CPU with timer interrupt, speed 0 MHz (estimated)
Profiling through timer interrupt
          TIMER:0|
  samples|      %|
------------------
     3253 99.1768 /usr/lib/debug/lib/modules/2.6.9-6.31.EL/vmlinux
       11  0.3354 /bin/bash
        9  0.2744 /lib/tls/libc-2.3.4.so
        3  0.0915 /ext3
        3  0.0915 /usr/bin/oprofiled
        1  0.0305 /jbd



Note You need to log in before you can comment on or make changes to this bug.