Bug 138839 - Cannot remove a logical volume with system-config-lvm
Summary: Cannot remove a logical volume with system-config-lvm
Status: CLOSED DUPLICATE of bug 137292
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 15:05 UTC by John Haxby
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Haxby 2004-11-11 15:05:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After my failed attempt to create a logical volume mounted on /media
in bug #128824 (which I now realise shouldn't've worked because /media
not only exists but it in use) I tried to delete the logical volume
and re-create it mounted somewhere else.   I can't :-(

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.3-1.0

How reproducible:
Always

Steps to Reproduce:
1. Choose the logical view in system-config-lvm
2. Select the logical volume you want to remove (it acquires some nice
white pinstripes to show it's been selected)
3. Click on "Remove Selected Logical Volumes(s)"
    

Actual Results:  A dialog box pops up saying "Are you quite certain
that you wish to remove the Logical Volume lv_media?"  (It's nice and
chatty, but perhaps a little overly verbose, but I'm being picky
here.)   When you click on "Yes" you get and error dialog box that
says 'lvremove command failed.  Command attempted "/usr/sbin/lvremove
--force lv_media".  This is clearly wrong since it doesn't specify the
volume group -- and an error message sent to the console (Volume group
"lv_media" not found) underlines this.

Also are you going to use gtk.main() instead of the deprecated
gtk.mainloop()?

Expected Results:  The volume group should've been removed.

Additional info:

If I select the logical volume by name from the left hand panel and
click on "Remove Logical Volume" it is actually removed.

Comment 1 John Haxby 2004-11-11 15:07:13 UTC
Sorry, I meant bug #138824.

Comment 2 Derek Anderson 2004-11-11 15:24:45 UTC
John, 
 
Thanks for your reports.  Please check existing Bugzilla reports for 
duplicates before filing.  This one is a duplicate.  Query under 
component 'system-config-lvm'. 

*** This bug has been marked as a duplicate of 137292 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:06:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.