Bug 138871 - Man pages in mc aren't converted to UTF-8
Man pages in mc aren't converted to UTF-8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 13:37 EST by Marcin Garski
Modified: 2013-07-02 19:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.6.1-0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 10:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Convert man pages to UTF-8 (1.19 KB, patch)
2004-11-11 13:38 EST, Marcin Garski
no flags Details | Diff

  None (edit)
Description Marcin Garski 2004-11-11 13:37:07 EST
Description of problem:
Man pages in mc aren't converted to UTF-8

Version-Release number of selected component (if applicable):
mc-4.6.1-0.9

Steps to Reproduce:
1.Try to view 'es|hu|it|pl|ru|sr' mc man page.
  
Actual results:
XXX
XXX WARNING: old character encoding and/or character set
XXX

Additional info:
See attached patch for resolving the problem.
Comment 1 Marcin Garski 2004-11-11 13:38:51 EST
Created attachment 106518 [details]
Convert man pages to UTF-8
Comment 2 Leonard den Ottolander 2004-11-11 17:04:00 EST
I don't think we should convert the .in files, but the resulting man
pages instead.

And what about the files in the root of /doc?

mc.1
mcedit.1
mcserv.8
xnc.hlp

Need those not be converted to UTF-8 as well?
Comment 3 Leonard den Ottolander 2004-11-11 17:14:59 EST
The last part (about the documents of root of /doc) is just a dumb
remark ;) .
Comment 4 Leonard den Ottolander 2004-11-11 17:32:01 EST
And the first remark also turns out to be a dumb one :( . I thought
the conversion was done after the build, which is not the case.
Comment 5 Jindrich Novy 2004-11-11 17:58:41 EST
Originally when updating spec for 0.9 release I decided not to convert
man pages to UTF-8 (as I originally did) because the most of users use
mc in non-utf-8 mode so the patch you've attached is exactly what I
did but not applied. The exact message of old character encoding is
displayed when you try to display man pages in non-UTF-8 mode after
the conversion.

Since majority of man pages are non-UTF8 I won't consider this as a
bug but the conversion is planned to be applied in some later release
of mc.

cheers,
Jindrich
Comment 6 Leonard den Ottolander 2004-11-11 18:13:49 EST
The default charset on Fedora Core is UTF-8. So it's probably best to
convert these pages and notify people who change their charset to
something different than UTF-8.

A README.FC would be handy for this.
Comment 7 Leonard den Ottolander 2004-11-11 18:15:03 EST
Another question is why you would convert the help pages but not the
man pages. Rather inconsistent.
Comment 8 Marcin Garski 2004-11-11 19:59:31 EST
Non-UTF-8 man pages in mc is a bug.
Majority of man pages are in UTF-8, just look i.e to spec file of
man-pages-{pl|cs|es}. ALL of them are converted to UTF-8 (also I've
filed a bug #138865 where Polish man page from this packages is in
conflict with the same but older mc man page from man-pages-pl, the
old one from man-pages-pl is already in UTF-8).

Leonard has also right, when he wrote about inconsisty.
BTW since release of RHL 8, Red Hat as one of the first ditro
releaser, has switched to UTF-8 as default encoding, so IMHO most RHL
and FC users use UTF-8), even there where bugs about lack of UTF-8
support in mc.
Comment 9 Jindrich Novy 2004-11-12 05:36:53 EST
Ok, you've convinced me. I'll add the conversion of man pages in the
next release.

I'll close this after it's built.

Note You need to log in before you can comment on or make changes to this bug.