Bug 1388765 - Item in "Content host" is always a short name when a server has HOSTNAME set without a domain name.
Summary: Item in "Content host" is always a short name when a server has HOSTNAME set ...
Keywords:
Status: CLOSED DUPLICATE of bug 1380473
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.2.2
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-26 07:29 UTC by Vladimir Dulava
Modified: 2017-04-25 16:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-31 18:45:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vladimir Dulava 2016-10-26 07:29:41 UTC
Description of problem:
Item in "Content host" is always a short name when a server has HOSTNAME set without a domain name if registered to satellite with subscription-manager command.

Version-Release number of selected component (if applicable):
Sat 6.2.2

How reproducible:
Try to register a host to satellite 6.2.2 with subscription-manager.
Even in case the FQDN was set correctly or the --name flag was used, the server was registered with short hostname.

Steps to Reproduce:
1. Register host to sat 6.2.2 from hosts cli
2. Check host name in sat gui
3. Check host name via hammer host list from sat cli

Actual results:
[root@mariachitest2 ~]# hammer host list
[Foreman] Password for admin: 
---|------------------------|------------------|------------|-------------|------------------
ID | NAME                   | OPERATING SYSTEM | HOST GROUP | IP          | MAC              
---|------------------------|------------------|------------|-------------|------------------
3  | mariachitest1          | RedHat 7.2       |            | 10.34.84.93 | 00:1a:4a:22:39:e5
1  | mariachitest2.rofl.lol | RedHat 7.2       |            | 10.34.84.90 | 00:1a:4a:22:39:e6
4  | mariachitest3          | RHEL Server 6.8  |            | 10.34.84.76 | 00:1a:4a:22:39:e9
---|------------------------|------------------|------------|-------------|------------------
[root@mariachitest2 ~]# 


Expected results:
[root@mariachitest2 ~]# hammer host list
[Foreman] Password for admin: 
---|------------------------|------------------|------------|-------------|------------------
ID | NAME                   | OPERATING SYSTEM | HOST GROUP | IP          | MAC              
---|------------------------|------------------|------------|-------------|------------------
3  | mariachitest1.rofl.lol | RedHat 7.2       |            | 10.34.84.93 | 00:1a:4a:22:39:e5
1  | mariachitest2.rofl.lol | RedHat 7.2       |            | 10.34.84.90 | 00:1a:4a:22:39:e6
4  | mariachitest3.rofl.lol | RHEL Server 6.8  |            | 10.34.84.76 | 00:1a:4a:22:39:e9
---|------------------------|------------------|------------|-------------|------------------
[root@mariachitest2 ~]# 


Additional info:

Comment 1 Brad Buckingham 2016-10-31 18:45:21 UTC
Based on feedback from Justin, this issue appears to be a duplicate of bug 1380473.

*** This bug has been marked as a duplicate of bug 1380473 ***


Note You need to log in before you can comment on or make changes to this bug.