Bug 138894 - FireWire disk accessibility interruption
FireWire disk accessibility interruption
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 15:41 EST by Michael Shapcotte
Modified: 2015-01-04 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 02:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Shapcotte 2004-11-11 15:41:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Attached FireWire disk fails to respond after a few seconds of access.
Disk is accessible again after a few seconds of unresponsiveness, only
to fail again. The following errors are produced in /var/log/messages:

Nov 11 12:07:28 donny kernel: ieee1394: sbp2: aborting sbp2 command
Nov 11 12:07:28 donny kernel: Read (10) 00 0a 20 5c 47 00 00 f8 00
Nov 11 12:07:58 donny kernel: ieee1394: sbp2: aborting sbp2 command
Nov 11 12:07:58 donny kernel: Read (10) 00 0a 20 5d 47 00 00 f8 00
Nov 11 12:09:07 donny kernel: ieee1394: sbp2: aborting sbp2 command
Nov 11 12:09:07 donny kernel: Read (10) 00 0a 20 5f df 00 00 f8 00

This particular FireWire disk has no problems working on the same
machine running Red Hat 9 with the shipping kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. attach FireWire drive to system
2. mount FireWire drive
3. access FireWire drive (chmod -R, play an mp3 file, etc.)
4. wait a few seconds
5. observe log or behavior of just-run command
    

Actual Results:  FireWire disk stops responding, holding up the
program accessing it. Errors listed in bug description field show up
in /var/log/messages or on the console.

Expected Results:  No errors, no delays in accessing the FireWire disk.

Additional info:

This particular FireWire disk has no problems working on the same
machine running Red Hat 9 with the shipping kernel.
Comment 1 Jeremy Rosengren 2004-11-21 02:39:53 EST
I'm seeing the same issue under Fedora Core 2 with updates kernel
2.6.9-1.3_FC2smp.

Nov 21 01:01:57 clunker kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 01:01:57 clunker kernel: Read (10) 00 09 45 cb a7 00 00 40 00 
          
Comment 2 Dennis DeDonatis 2004-11-23 13:17:54 EST
I check to see if this problem is fixed in just about every new 
version of the kernel that comes out.  The problem is still there in 
2.6.9-1.681_FC3.  I think it has been there since FC1.

Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 16 7f 00 00 08 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 16 af 00 00 28 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 16 df 00 00 28 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 17 1f 00 00 38 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 17 67 00 00 20 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 17 97 00 00 10 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 17 cf 00 00 30 00
Nov 21 16:54:26 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:26 linux01 kernel: Read (10) 00 03 45 18 1f 00 00 10 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b4 4f 00 00 20 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b4 87 00 00 10 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b4 b7 00 00 18 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b4 df 00 00 10 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b4 ff 00 00 18 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b5 1f 00 00 10 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b5 3f 00 00 10 00
Nov 21 16:54:57 linux01 kernel: ieee1394: sbp2: aborting sbp2 command
Nov 21 16:54:57 linux01 kernel: Read (10) 00 03 45 b5 5f 00 00 20 00

If you put this in /etc/modprobe.conf:
options sbp2 serialize_io=1

and them make sure to re-run mkinitrd with --omit-scsi-modules so it 
will actually see it, the problem goes away (but with a performance 
penalty) for the most part.  If you DO some one of those "aborting 
sbp2 command" with the serialize_io=1, the computer will lock up 
within a week.  I now reboot as soon as I can if I see that error and 
I have the serialize_io=1 set (about once every 3-4 months).

You might not want to --omit-scsi-modules if you boot off of a SCSI 
hard drive.
Comment 3 Andrew Lare 2005-01-07 10:43:09 EST
I also see this with kernel 2.6.9-1.11.
Comment 4 Jeremy Rosengren 2005-01-07 11:13:16 EST
I haven't seen this on FC2 using at least the last two updated kernels
(currently, I'm using 2.6.9-1.11) and serialize_io=1.
Comment 5 Andrew Lare 2005-01-13 11:45:02 EST
I tried using the serialize_io=1 option, but I am still seeing the
same error messages.
Comment 6 Dave Jones 2005-07-15 14:09:16 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Andrew Lare 2005-07-28 10:31:52 EDT
As far as I can tell, it has been corrected both in the latest kernel versions
for both Fedora Core 3 and 4.

Note You need to log in before you can comment on or make changes to this bug.