Bug 138926 - net ads join segmentation fault
net ads join segmentation fault
Status: CLOSED DUPLICATE of bug 164353
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Samba 3.0.8 from samba.org doesn't ha...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 18:09 EST by Dan Davis
Modified: 2014-08-31 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 05:23:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debugging session output/stack trace (10.61 KB, text/plain)
2004-11-11 18:11 EST, Dan Davis
no flags Details

  None (edit)
Description Dan Davis 2004-11-11 18:09:11 EST
Description of problem:
  net ads join fails with a segmentation fault on x86_64 systems.
  The failure occurs fairly late in the process - the computer 
  account has already been created in Active Directory, etc.
  SELinux is disabled, as is iptables.  The problem does not occur
  on FC2 on i386.  I don't yet have any FC2 x86_64 or FC3 i386
  systems.

Version-Release number of selected component (if applicable):
  Since the backtrace shows that /usr/bin/net is calling into
  openldap, I'll give you both, from my most yum updated system.

  samba-client-3.0.8-0.pre1.3
  openldap-2.2.13-2

How reproducible:
  Configure winbind on an FC3 x86_64 box, and join the new computer
  to the domain once names are established.

Stack trace:

Program received signal SIGSEGV, Segmentation fault.
0x0000002a96092590 in ldap_msgfree () from /usr/lib64/libldap-2.2.so.7
(gdb) bt
#0  0x0000002a96092590 in ldap_msgfree () from /usr/lib64/libldap-2.2.so.7
#1  0x000000552abe5e45 in ads_workgroup_name () from /usr/bin/net
#2  0x000000552aaeae85 in net_ads_join () from /usr/bin/net
#3  0x000000552aaec1e5 in net_ads () from /usr/bin/net
#4  0x000000552aae95b0 in main () from /usr/bin/net
(gdb) quit
Comment 1 Dan Davis 2004-11-11 18:11:12 EST
Created attachment 106536 [details]
Debugging session output/stack trace
Comment 2 Dan Davis 2004-11-12 14:38:58 EST
Just one more note - the samba-3.0.8 tarball directly from samba.org
doesn't have this problem.  I haven't investigated the diffs and will
not patch, since I can now continue with my work.

Let me know, when I no longer need to compile the samba-3.0.8 tarball
directly.  My employer's workstations update to FC3 only after this
problem is fixed.
Comment 3 Charles Liebow 2005-01-06 20:57:54 EST
3.0.8 also segfaults in rhel4 beta 2 at same point using winbind..
Comment 4 Maxim Britov 2005-06-27 09:29:54 EDT
I just got (FC current with generic kernel 2.6.12):

# net ads join -U admin
admin's password:
[2005/06/27 16:11:10, 0] libads/ldap.c:ads_add_machine_acct(1405)
  ads_add_machine_acct: Host account for proxy already exists - modifying old
account
Using short domain name -- DOMAIN
Joined 'SOMEPC' to realm 'SOME.DOMAIN.BY'
*** glibc detected *** net: free(): invalid pointer: 0xb7ed8dd0 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7d31384]
/lib/libc.so.6(__libc_free+0x77)[0xb7d318bf]
/lib/libcom_err.so.2(remove_error_table+0x4b)[0xb7e3dabb]
/usr/lib/libkrb5.so.3[0xb7e768c4]
/usr/lib/libkrb5.so.3[0xb7e765c7]
/usr/lib/libkrb5.so.3[0xb7ec79fa]
/lib/ld-linux.so.2[0x4ac412b8]
/lib/libc.so.6(exit+0xc5)[0xb7cf8bc9]
/lib/libc.so.6(__libc_start_main+0xce)[0xb7ce2d4e]
net[0x8002d0f1]
======= Memory map: ========
4ac33000-4ac4d000 r-xp 00000000 03:02 25174645   /lib/ld-2.3.5.so
4ac4d000-4ac4e000 r--p 00019000 03:02 25174645   /lib/ld-2.3.5.so
4ac4e000-4ac4f000 rw-p 0001a000 03:02 25174645   /lib/ld-2.3.5.so
80000000-801c4000 r-xp 00000000 03:02 92327636   /usr/bin/net
801c4000-801d5000 rw-p 001c4000 03:02 92327636   /usr/bin/net
801d5000-8028c000 rw-p 801d5000 00:00 0          [heap]
b7700000-b7721000 rw-p b7700000 00:00 0
b7721000-b7800000 ---p b7721000 00:00 0
b78d6000-b78df000 r-xp 00000000 03:02 25167044   /lib/libgcc_s-4.0.0-20050622.so.1
b78df000-b78e0000 rw-p 00009000 03:02 25167044   /lib/libgcc_s-4.0.0-20050622.so.1
b78e0000-b78e9000 r-xp 00000000 03:02 25174440   /lib/libnss_files-2.3.5.so
b78e9000-b78ea000 r--p 00008000 03:02 25174440   /lib/libnss_files-2.3.5.so
b78ea000-b78eb000 rw-p 00009000 03:02 25174440   /lib/libnss_files-2.3.5.so
b7900000-b7902000 rw-s 00000000 03:02 13578103   /var/cache/samba/gencache.tdb
b7902000-b7904000 rw-s 00000000 03:02 117441654  /etc/samba/secrets.tdb
b7904000-b7914000 r--s 00000000 03:02 84060375   /usr/lib/samba/valid.dat
b7914000-b7934000 r--s 00000000 03:02 84060376   /usr/lib/samba/lowcase.dat
b7934000-b7954000 r--s 00000000 03:02 84060374   /usr/lib/samba/upcase.dat
b7954000-b7956000 r-xp 00000000 03:02 16887858   /usr/lib/gconv/UTF-16.so
b7956000-b7958000 rw-p 00001000 03:02 16887858   /usr/lib/gconv/UTF-16.so
b7958000-b795e000 r--s 00000000 03:02 16887849   /usr/lib/gconv/gconv-modules.cache
b795e000-b7b5e000 r--p 00000000 03:02 11981305   /usr/lib/locale/locale-archive
b7b5e000-b7b60000 rw-p b7b5e000 00:00 0
b7b60000-b7b72000 r-xp 00000000 03:02 92609900   /usr/lib/libz.so.1.2.2.2
b7b72000-b7b73000 rw-p 00011000 03:02 92609900   /usr/lib/libz.so.1.2.2.2
b7b73000-b7c6b000 r-xp 00000000 03:02 25200453   /lib/libcrypto.so.0.9.7f
b7c6b000-b7c7d000 rw-p 000f8000 03:02 25200453   /lib/libcrypto.so.0.9.7f
b7c7d000-b7c80000 rw-p b7c7d000 00:00 0
b7c80000-b7cb5000 r-xp 00000000 03:02 25200454   /lib/libssl.so.0.9.7f
b7cb5000-b7cb8000 rw-p 00035000 03:02 25200454   /lib/libssl.so.0.9.7f
b7cb8000-b7ccd000 r-xp 00000000 03:02 93949587   /usr/lib/libsasl2.so.2.0.20
b7ccd000-b7cce000 rw-p 00015000 03:02 93949587   /usr/lib/libsasl2.so.2.0.20
b7cce000-b7df2000 r-xp 00000000 03:02 25174646   /lib/libc-2.3.5.so
b7df2000-b7df4000 r--p 00124000 03:02 25174646   /lib/libc-2.3.5.so
b7df4000-b7df6000 rw-p 00126000 03:02 25174646   /lib/libc-2.3.5.so
b7df6000-b7df9000 rw-p b7df6000 00:00 0
b7df9000-b7e06000 r-xp 00000000 03:02 92327911   /usr/lib/liblber-2.2.so.7.0.19
b7e06000-b7e07000 rw-p 0000c000 03:02 92327911   /usr/lib/liblber-2.2.so.7.0.19
b7e07000-b7e3b000 r-xp 00000000 03:02 93949588   /usr/lib/libldap-2.2.so.7.0.19
b7e3b000-b7e3d000 rw-p 00033000 03:02 93949588   /usr/lib/libldap-2.2.so.7.0.19
b7e3d000-b7e3f000 r-xp 00000000 03:02 25200452   /lib/libcom_err.so.2.1
b7e3f000-b7e40000 rw-p 00001000 03:02 25200452   /lib/libcom_err.so.2.1
b7e40000-b7e42000 r-xp 00000000 03:02 93835281   /usr/lib/libkrb5support.so.0.0
b7e42000-b7e43000 rw-p 00001000 03:02 93835281   /usr/lib/libkrb5support.so.0.0
b7e43000-b7e66000 r-xp 00000000 03:02 93835287   /usr/lib/libk5crypto.so.3.0
b7e66000-b7e67000 rw-p 00023000 03:02 93835287   /usr/lib/libk5crypto.so.3.0
b7e67000-b7ed6000 r-xp 00000000 03:02 93835306   /usr/lib/libkrb5.so.3.2
b7ed6000-b7ed9000 rw-p 0006e000 03:02 93835306   /usr/lib/libkrb5.so.3.2
b7ed9000-b7eda000 rw-p b7ed9000 00:00 0
b7eda000-b7ef1000 r-xp 00000000 03:02 93835318   /usr/lib/libgssapi_krb5.so.2.2
b7ef1000-b7ef2000 rw-p 00017000 03:02 93835318   /usr/lib/libgssapi_krb5.so.2.2
b7ef2000-b7ef9000 r-Аварийный останов
Comment 5 Marius Andreiana 2005-11-03 05:23:37 EST
Marking as dupe of a more recent report, which has more CCs


*** This bug has been marked as a duplicate of 164353 ***

Note You need to log in before you can comment on or make changes to this bug.