Bug 138936 - 'confname' referenced before assignment
'confname' referenced before assignment
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 19:18 EST by james
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-14 12:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2004-11-11 19:18:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.54  [en]

Description of problem:

#yum update
...
--> Running transaction check
...
--> Processing Dependency: ecj= 2.1.3-4 for package: ecj-devel
--> Processing Conflict: postgresql-python conflicts python>= 2.4
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 174, 
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 190, 
in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self.
_processConflict(dep)
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 492, 
in _processConflict
    uplist = self.up.getUpdatesList(name=confname)
UnboundLocalError: local variable 'confname' referenced before 
assignment



Version-Release number of selected component (if applicable):
yum-2.1.11-3

How reproducible:
Always

Steps to Reproduce:
1.package configuration dependent
2.yum update
3.
    

Additional info:
Comment 1 Seth Vidal 2004-11-14 12:33:12 EST
Duplicate of upstream bug
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=353

Note You need to log in before you can comment on or make changes to this bug.