Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1389522 - [RFE] Restricting project names [NEEDINFO]
[RFE] Restricting project names
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michal Fojtik
ge liu
:
Depends On: 1306024
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-27 15:19 EDT by Ryan Howe
Modified: 2018-03-12 09:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1306024
Environment:
Last Closed: 2018-03-12 09:54:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
erich: needinfo? (rhowe)


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2016-10-27 15:19:32 EDT
RFE to track trello 

https://trello.com/c/vllOT4mI/613-provide-a-way-to-limit-names-of-projects-created-by-end-users-to-a-name-based-on-user-information



+++ This bug was initially created as a clone of Bug #1306024 +++

Description of problem:
I am in the need of restricting the project count and the name a user can have. I have been provided with: https://github.com/openshift/origin/pull/6571 and https://github.com/openshift/openshift-docs/pull/1476/files as pointers by rjhowe@redhat.com. Based on the information he mentioned that this in upstream with possible 3.2 release. 

In our environment (education space), it is a pretty important thing to have as resources are a bit more finite and project count limits in conjunction with resource quota and limits allows us to maximize what we offer our customers for free.

The second part of the bug report neither myself nor Ryan have been able to find much info on. In v2 currently, we are able to restrict the namespace by doing a couple of simple code modifications which allow us to restrict the project name to the user's username (as an example), thus providing a simple audit trail for troubleshooting/etc. Will there be any chance of getting this functionality added, as modifying v3 is a bit harder than it is with v2 :)?

--- Additional comment from Dan McPherson on 2016-02-10 09:37:16 EST ---

This is related:

https://trello.com/c/GsCfvXWA

Will release with 3.2.  This will allow you to configure the system so only N projects can be created per user.

--- Additional comment from Boris Kurktchiev on 2016-02-10 09:48:42 EST ---

So I am guessing that my second request should be filed as an RFE? Also, there is one last thing that we are currently able to do in v2 with a few lines of code changed. The public hostname of a route. Right now we can only limit to say *.ose.devapps.unc.edu in v3, but is there some mechanism to insert say their username for their project ex: User: boris hostnames available: *-boris.ose.devapps.unc.edu

--- Additional comment from Cesar Wong on 2016-02-10 10:05:43 EST ---

I've created a Trello card for the second part here: https://trello.com/c/vllOT4mI/613-provide-a-way-to-limit-names-of-projects-created-by-end-users-to-a-name-based-on-user-information

--- Additional comment from Cesar Wong on 2016-02-10 10:06:56 EST ---

Boris there isn't a current mechanism that I know of to default the route name. Sounds like another RFE.

--- Additional comment from Dan McPherson on 2016-04-15 09:14:53 EDT ---

This is similar to: https://bugzilla.redhat.com/show_bug.cgi?id=1257760

--- Additional comment from weiwei jiang on 2016-05-06 06:48:22 EDT ---

Since the feature "project request limitation" will be released in 3.2, so verify this.
Comment 1 Boris Kurktchiev 2016-10-27 15:46:50 EDT
So I am reading through the trello card and just noticed this addition that I dont remember seeing before "We can already append a username to the project today - does this help (issue above still applies)?", is this available in OCP 3.3 and if so is there a doc somewhere (i am searching and not coming up with anything)
Comment 2 Boris Kurktchiev 2016-10-28 09:56:55 EDT
Well dug around and found it https://docs.openshift.com/container-platform/3.3/install_config/router/default_haproxy_router.html#customizing-the-default-routing-subdomain seems to do most of what the initial RFE requested.
Comment 4 Eric Rich 2018-03-12 09:54:36 EDT
This bug has been identified as a dated (created more than 3 months ago) bug. 
This bug has been triaged (has a trello card linked to it), or reviewed by Engineering/PM and has been put into the product backlog, 
however this bug has not been slated for a currently planned release (3.9, 3.10 or 3.11), which cover our releases for the rest of the calendar year. 

As a result of this bugs age, state on the current roadmap and PM Score (being below 70), this bug is being Closed - Differed, 
as it is currently not part of the products immediate priorities.

Please see: https://docs.google.com/document/d/1zdqF4rB3ea8GmVIZ7qWCVYUaQ7-EexUrQEF0MTwdDkw/edit for more details.

Note You need to log in before you can comment on or make changes to this bug.