Bug 138969 - broken initrd after upgrade FC2->FC3
broken initrd after upgrade FC2->FC3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 03:52 EST by Ben Hsu
Modified: 2015-01-04 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 04:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf (870 bytes, text/plain)
2004-11-12 03:54 EST, Ben Hsu
no flags Details

  None (edit)
Description Ben Hsu 2004-11-12 03:52:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
My system has /boot located on /dev/hda3 and root filesystem located
on /dev/hda5. After I upgraded from FC2 to FC3, the system kernel
panics on boot.


I booted to a rescue CD and editted grub to point to a previous
kernel, that got me a usable system.





Version-Release number of selected component (if applicable):
2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. get FC2 system
2. upgrade
3. boot
    

Actual Results:  kernel panic

Expected Results:  successful boot

Additional info:

Error log (I could not capture it so I'm typing this by hand)
<message of Nash starting>
mount: missing device
ERROR: failed in exec of defaults
ERROR: failed in exec of ext3
mount: error 2 mounting none
switchroot: mount failed 22
umount /initrd/dev failed: 2
ERROR: failed in exec of ext3
mount: error 2 mounting none
switchroot: mount failed 22
umount /initrd/dev failed: 2
ERROR: defaults exited abnormally
ERROR: failed in exec of ext3
mount: error 2 mounting none
switchroot: mount failed 22
umount /initrd/dev failed: 2
ERROR: failed in exec of ext3
mount: error 2 mounting none
switchroot: mount failed 22
umount /initrd/dev failed: 2
Kernel panic, not synching, attempted to kill init.
Comment 1 Ben Hsu 2004-11-12 03:54:48 EST
Created attachment 106555 [details]
grub.conf

my grub.conf file with the sections using the old kernel and the FC3 kernel
(marked "does not work")
Comment 2 Jerry 2004-11-13 00:19:21 EST
This looks like the same bug I reported in 139143
Comment 3 Levi 2004-11-18 15:10:07 EST
I installed FC3 on my pc (Asus P4P800, 2.8 MHz CPU, 1 Sata 120 GB HD,
ATi Radeon 9600 VGA, 1 GB MEM) and the default kernel
(kernel-smp-2.6.9-1.667) is working ok. When I done yum update, the
new kernel (kernel-smp-2.6.9-1.678_FC3) is hang same kernel panic.
Comment 4 Dave Jones 2005-07-15 15:48:05 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Ben Hsu 2005-07-15 23:48:11 EDT
this still reproduces with the updated kernel (2.6.12-1.1372_FC3). I have not
had a chance to upgrade to FC4
Comment 6 Ben Hsu 2005-07-15 23:49:02 EDT
this still reproduces with the updated kernel (2.6.12-1.1372_FC3). I have not
had a chance to upgrade to FC4
Comment 7 Dave Jones 2005-08-04 13:54:26 EDT
can you make sure you have the latest updated mkinitrd package installed ?
If not, update it, then remove and reinstall the kernel update.


If you still have problems, can you attach your /etc/modprobe.conf please ?

Note You need to log in before you can comment on or make changes to this bug.