Bug 138977 - warning is shown when "gcore" command run on RHEL4
warning is shown when "gcore" command run on RHEL4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 06:07 EST by L3support
Modified: 2013-03-06 00:58 EST (History)
8 users (show)

See Also:
Fixed In Version: RHEL4 U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-15 18:05:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample test used to create strace attachment (75 bytes, application/octet-stream)
2005-01-24 17:17 EST, Jeff Johnston
no flags Details
Gdb command file used when creating strace output (17 bytes, application/octet-stream)
2005-01-24 17:18 EST, Jeff Johnston
no flags Details
Strace of gdb running gcore command (2.41 MB, application/octet-stream)
2005-01-24 17:19 EST, Jeff Johnston
no flags Details
Maps file for process that caused problem with gcore (863 bytes, text/plain)
2005-01-24 17:20 EST, Jeff Johnston
no flags Details

  None (edit)
Description L3support 2004-11-12 06:07:57 EST
Description of problem:

The following warning is shown,
when we run "gcore" command on RHEL4.

warning: Memory read failed for corefile section, 16384 bytes at
0x0000000000000000

The warning is not shown,
when we run "gcore" command on RHEL3.

What should we do to the warning ?

Can we have how to aboid to the warning ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

1.ps -ef
2.gcore (PID)
  -- PID: I selected PID that UID is demon and CMD is "/usr/sbin/atd".

Actual results:
warning: Memory read failed for corefile section, 16384 bytes at
0x0000000000000000


Expected results:

 - What should we do to the warning ?
 - Can we have how to aboid to the warning ?

Additional info:
Comment 2 L3support 2004-11-26 00:16:34 EST
Could you tell me status of this problem ?
Comment 3 L3support 2004-12-13 01:33:04 EST
We'd like to know status of problem.
Comment 4 L3support 2005-01-05 01:44:02 EST
We'd like to know status of problem.
Comment 5 RHEL4-L3support 2005-01-18 21:04:05 EST
Add RHEL4-L3support team in Japan
Comment 7 Jeff Johnston 2005-01-24 17:14:22 EST
Bug is being moved to kernel group for assistance.  Gdb is getting an error back
from reading memory at 00000000-00004000 which is the first entry in the "maps"
file for the process.  The storage is marked readable but the PTRACE call to
read this storage results in an EIO failure as detailed in the strace output I
am attaching.  I created the result by running the debugger on a simple hello
world program, stopping in main, and issuing gcore.  For the kernel folks, the
failure can be reproduced by running as follows:

gcc -g test.c
gdb -x t.x a.out

I have tried multiple versions of gdb, but they all result in the warning due to
the failed PTRACE read.
Comment 8 Jeff Johnston 2005-01-24 17:17:18 EST
Created attachment 110165 [details]
Sample test used to create strace attachment
Comment 9 Jeff Johnston 2005-01-24 17:18:12 EST
Created attachment 110166 [details]
Gdb command file used when creating strace output
Comment 10 Jeff Johnston 2005-01-24 17:19:13 EST
Created attachment 110167 [details]
Strace of gdb running gcore command
Comment 11 Jeff Johnston 2005-01-24 17:20:07 EST
Created attachment 110168 [details]
Maps file for process that caused problem with gcore
Comment 14 Issue Tracker 2005-02-17 15:58:36 EST
From User-Agent: XML-RPC

As the corefile is being created properly without that piece of storage in
it, and the message shown is just a warning, and is not actually causing
any failure this issue/BZ is being closed as 'not a bug'.



If there is some other reason this is causing a problem, please re-open
this issue tracker with the appropriate information and details as well as
priority. 



 




Internal Status set to 'Resolved'
Status set to: Closed by Tech

Resolution set to: 'NotABug'

This event sent from IssueTracker by halligan
 issue 66082
Comment 18 Jeff Johnston 2005-04-21 16:07:54 EDT
I have reviewed the patch from Fujitsu.  I have modified it only slightly for
formatting and have built it into gdb-6.3.0.0-1.13
Comment 29 Jeff Johnston 2005-07-28 11:51:02 EDT
This has been fixed as of gdb-6.3.0.0-1.14
Comment 32 Jeff Johnston 2005-11-15 18:05:12 EST
Customer has confirmed fix.

Note You need to log in before you can comment on or make changes to this bug.