Bug 138984 - ugly standard bookmark icon
Summary: ugly standard bookmark icon
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-12 12:03 UTC by Enrico Scholz
Modified: 2013-03-13 04:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 14:01:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox screenshot (15.68 KB, image/png)
2004-11-12 12:04 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2004-11-12 12:03:07 UTC
Description of problem:

The standard bookmark icon is ugly: it is too colorful and looks like
a favicon. The difference between a meaningful favicon (which helps to
identify the page on the first look) and a placeholder icon should be
more visible.

E.g. look at the following screenshot... the "old" icon (left) is
plain and simple, the "new" one is intrusive.



Version-Release number of selected component (if applicable):

firefox-1.0-1

Comment 1 Enrico Scholz 2004-11-12 12:04:17 UTC
Created attachment 106558 [details]
firefox screenshot

Comment 2 Enrico Scholz 2005-04-19 11:39:45 UTC
ping...

still with firefox-1.0.3-2

Comment 3 Christopher Aillon 2005-06-06 18:11:31 UTC
Not a firefox issue, and not going to get fixed in firefox which just requests
the icons from GNOME.  Get this fixed in GNOME if you want it changed.

Comment 4 Enrico Scholz 2005-06-06 18:20:36 UTC
Sorry, it is an issue of the rawhide/FC4 firefox. Vanilla firefox has nice icons
but the additional patches are making it looking terribly.

Comment 5 Rahul Sundaram 2005-09-05 02:24:06 UTC
Firefox patches for integration with GNOME are getting upstream. The Bookmark
icon comes from the default GNOME theme. Reassiging to redhat-artwork

Comment 6 Warren Togami 2005-09-05 03:04:45 UTC
redhat-artwork does not contain upstream icons.  GNOME contains its own icons,
and we no longer use Bluecurve by default.

Comment 7 Enrico Scholz 2005-09-05 06:18:02 UTC
It is an firefox issue: when removing patches 25-29 (afair) in the firefox
src.rpm (without changing anything at gnome), icons are nice again.

Comment 8 John (J5) Palmieri 2005-09-06 03:21:33 UTC
We do use Bluecurve icons still as the default GNOME ones have not been updated
to match the Clearlook theme.

Icons are picked up by firefox from this theme as we want to present a
conisitent look across all apps.  These icons may change from time to time as
our artists see fit.  I will bring up your concerns with the resident artists
but as icons are subjective they may find it satisfactory.  Because of this I am
going to close this as not a bug.  If they feel it is an issue they will update
the icon when they can get to it. 

Comment 9 Enrico Scholz 2005-09-06 05:54:48 UTC
It is a firefox bug. There is no need to use icons from other packages as the
default firefox icons are nice. 

Why are the icons taken from Gnome2? What is with people using E, KDE, ...?
Those people will not see the "consistent look across all apps".

So it would be best to remove the responsible patches until a way is found to
choose between the original (nice) Firefox icons and these of your Desktop
environment.

Comment 10 John (J5) Palmieri 2005-09-06 14:01:22 UTC
Please do not reopen bugs.  I explained why.  If people are using KDE, E, etc.
and  use an icon theme from the Freedesktop icon spec it will pick up those
icons.  Everyone has a different opinion of astetics. Your other option is to
pick a new theme or create one that has the icons you would like to see.

Comment 11 John (J5) Palmieri 2005-09-06 14:04:25 UTC
BTW, it is easy to do.  You can create a new theme that inherits from Bluecurve
so only the icons you want to change are changed and you still get other updates
as the Bluecurve icon set evolves.


Note You need to log in before you can comment on or make changes to this bug.