Bug 139007 - gnome-media doesn't properly support RME Digi96/8 PST soundcard
Summary: gnome-media doesn't properly support RME Digi96/8 PST soundcard
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-12 14:50 UTC by Dave Maley
Modified: 2013-03-13 04:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 17:32:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Maley 2004-11-12 14:50:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
The gnome-volume-manager is only showing 2 slider controls (R/L),
labelled as DAC.  The RME Digi96/8 PST card has digital (optical,
coax, and internal CDROM) as well as analog and adat interfaces.

The gamix mixer app seems to correctly support the interfaces of this
card.  Maybe gnome-volume-manager could "learn" this from gamix?  I
always grab gamix from:

   http://ccrma.stanford.edu/planetccrma/software/

It looks like this is the homepage but I can't tell for sure since
it's in Japanese:

   http://www1.tcnet.ne.jp/fmurata/linux/alsa.html

If there's anything I can do to help getting this support added to
gnome-volume-manager just let me know.

Thanks!

Version-Release number of selected component (if applicable):
gnome-volume-manager-1.1.0-5

How reproducible:
Always

Steps to Reproduce:
1.on a system w/ a RME Digi96/8 PST soundcard open gnome-volume-manager
2.
3.
    

Actual Results:  only 2 slider controls

Expected Results:  multiple sliders and/or dropdowns to select the
different inputs.

Additional info:

Comment 1 John (J5) Palmieri 2004-11-12 14:53:45 UTC
gnome-volume-manager manages disk volumes ;-).  Reassigning to
system-config-soundcard

Comment 2 John (J5) Palmieri 2004-11-12 14:55:43 UTC
Opps that should be gnome-media

Comment 3 Dave Maley 2004-11-13 07:36:06 UTC
Don't know if it helps you w/ this but I just stumbled accross another
app which supports this card _very_ nicely.  Almost a clone of the
actual RME mixer gui.  It's a fairly small tk script called TkDigi
which front-ends for amixer.  It can be found here:

     http://www.uni-koblenz.de/~phil/tkdigi/

If there's any additional info or any testing I can do just let me
know ...

Thanks

Comment 4 Dave Maley 2004-11-13 09:01:32 UTC
sigh ... and after yet a bit more searching I've found that the
alsa-tools package contains rmedigicontrol, which is an excellent
little mixer app for this soundcard.  Right up there w/ the RME
provided app for windoze.

After thinking more about this it's perfectly reasonable that this
series of soundcards would have their own speciality mixer app.  This
is the case w/ windoze and I believe macs too.  So, I guess this has
turned into a request to include the alsa-tools package in Fedora ...

thanks

Comment 5 Dave Maley 2005-12-13 17:32:31 UTC
alsa-tools is available from Fedora Extras ... closing


Note You need to log in before you can comment on or make changes to this bug.