Bug 139010 - snmpd crash with 'interfaces' directives in snmpd.conf
snmpd crash with 'interfaces' directives in snmpd.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 10:02 EST by Fabrice Bellet
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 07:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2004-11-12 10:02:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
the bug described here
(https://sourceforge.net/tracker/?func=detail&atid=112694&aid=1052178&group_id=12694)
applies to the net-snmp version shipped in FC3. The one-liner fix
provided at the same place works for me. So, maybe it is worth to
integrate it in an updated package for FC3 ? (rawhide net-snmp is
older than the  FC3 package currently)

Best wishes,

PS : a second pointer needs to be initialized too, so the patch that
works for me is :

--- net-snmp-5.1.2/agent/mibgroup/mibII/interfaces.c.orig      
2004-07-23 02:55:41.000000000 +0200
+++ net-snmp-5.1.2/agent/mibgroup/mibII/interfaces.c    2004-11-12
15:51:53.751821909 +0100
@@ -322,9 +322,9 @@
     struct _conf_if_list *next;
 } conf_if_list;

-static conf_if_list *conf_list;
+static conf_if_list *conf_list = NULL;
 #ifdef linux
-static struct ifnet *ifnetaddr_list;
+static struct ifnet *ifnetaddr_list = NULL;
 #endif

 static void
Comment 1 Radek Vokal 2004-11-16 07:17:26 EST
Patch added to net-snmp-5.1.2-12. Should be in rawhide already. 
Comment 2 Fabrice Bellet 2004-11-16 12:32:18 EST
It works for me. thanks!
Comment 3 Gilbert E. Detillieux 2005-01-17 17:46:53 EST
Will this be issued as an update package for FC3?  SEGV errors are
rather serious.  On one of my servers, snmpd consistently dies anytime
you try to start the service.

Note You need to log in before you can comment on or make changes to this bug.