This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139016 - User preferences broken after upgrade
User preferences broken after upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 10:21 EST by Steve Hill
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 05:42:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2004-11-12 10:21:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After an upgrade from Fedora Core 2 -> Fedora Core 3, user's gnome
preferences are not applied.  e.g. font settings, menu/toolbar
settings, screensaver settings, etc.

For example, the icons in the menus were turned on before upgrading,
but after the upgrade none of the menus display any icons.  The
menu/toolbar preferences dialogue claims they are still turned on. 
Toggling them off and then on again restores their operation.

Version-Release number of selected component (if applicable):
2.8.0-3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to FC3
2.
3.
    

Actual Results:  Icons in menus are not displayed, fonts are obviously
not anti-aliased anymore, xscreensaver not running.

Expected Results:  Preferences should be left unaltered.

Additional info:

I am using Sawfish on all my machines instead of Metacity, but since
this is a problem with the Gnome panel settings, etc I don't believe
this is relevent.
Comment 1 Mark McLoughlin 2004-11-15 04:00:49 EST
Any GConf error messages in /var/log/messages?
Comment 2 Steve Hill 2004-11-16 04:26:57 EST
The only references to gconf in /var/log/messages are below. 
Additionally, a brand new user (i.e. no pre-existing configuration)
suffers the same problems.  I have managed to fix the problem on my
system by removing all of the gnome and gconf RPMS and everything that
depends on them, then removing /etc/gconf and then reinstalling all of
the RPMs.

Nov 12 19:12:16 rivendell gconfd (steve-11341): starting (version
2.8.1), pid 11341 user 'steve'
Nov 12 19:12:16 rivendell gconfd (steve-11341): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only
configuration source at position 0
Nov 12 19:12:16 rivendell gconfd (steve-11341): Resolved address
"xml:readwrite:/home/steve/.gconf" to a writable configuration source
at position 1
Nov 12 19:12:16 rivendell gconfd (steve-11341): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only
configuration source at position 2
Nov 12 19:12:27 rivendell gconfd (steve-11341): Resolved address
"xml:readwrite:/home/steve/.gconf" to a writable configuration source
at position 0
Comment 3 Mark McLoughlin 2004-12-14 05:42:05 EST
Sorry for leaving this sitting here ...

There's not much we can do without some idea of where the problem was
- e.g. a tarball of /etc/gconf while the problem was occurring,
details of any error messages while you upgraded, whether
gnome-settings-daemon was running ...

I suspect, though, that since you've re-installed etc. we've lost the
opportunity to figure out what caused it.

Note You need to log in before you can comment on or make changes to this bug.