Bug 13903 - Kickstart fails to correctly set hostname
Kickstart fails to correctly set hostname
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 10:00 EDT by laurence
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 10:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description laurence 2000-07-13 10:00:58 EDT
Using the following ks.cfg and simplified versions thereof, the --hostname directive will fail to actually set the hostname.  (Tested and confirmed 
by borgan@redhat.com)  I'm not sure if other methods of install will have the same trouble, because I am not set up to test those methods, but 
when using the following file on plain boot image (not net, etc) from a floppy with a cd install, your hostname remains localhost.localdomain.

### Language Specification
#lang ru_RU.KOI8-R 
lang en_US

### Network Configuration
network --bootproto static --ip 192.168.6.231 --netmask 255.255.255.0 --gateway 192.168.6.1 --nameserver 10.0.0.1 --hostname 
test.hostname.org

### Source File Location
cdrom

### Keyboard Configuration
keyboard us

### Partitioning Information
### Whether to clear out the Master Boot Record (yes/no)
### Which partitions to format (--linux/--all)
###      --linux - only format existing linux partitions
###      --all   - format all existing partitions
### Which partitions to set up on new system as well 
### as size of those partitions
zerombr yes
clearpart --all
part / --size 200
part swap --size 512
part /tmp --size 100
part /home --size 700
part /opt --size 2000
part /usr --size 2000
part /var --size 1000
part /usr/local --size 1 --grow
#part raid.0 --size 80
#part raid.1 --size 80
#raid swap raid.0 raid.1 --level 1 --device md0
install

### Mouse Configuration
### Will only setup 3 types of mice
###     generic        - 2-button serial
###     genericps/2    - 2-button ps/2
###     msintellips/2  - MS Intellimouse
### All three can be setup with or without 3-button
### emulation
### Run 'mouseconfig --help' in order to see other
### supported mouse type and make appropriate change
### NOTE: You will need to run 'mouseconfig' manually
### after installation if you have a non-ps/2 mouse
### and are installing X, as a ps/2 mouse is setup
### by default
#mouse generic --device ttyS0
mouse generic3ps/2

### Time Zone Configuration
### Will get set to 'US/Eastern' if ZONE is missing
### from /etc/sysconfig/clock or if file is missing entirely
timezone  US/Eastern

### X Configuration
### Will set up system for minimal resolution and color depth;
### may wish to run Xconfigurator manually after system installation
xconfig --server "SVGA" --monitor "Optiquest Q95"

### Root Password Designation
### '--iscrypted' does not work properly with release 6.1 as shipped;
### will need to get updates from http://support.redhat.com/errata
### in order for this to work correctly; can also just specify
### root password in plain text and change it after system installation;
### e.g. 'rootpw ThisIsThePassword' will get root's password to
### "ThisIsThePassword"
rootpw xx

### Authorization Configuration
#auth --useshadow --enablemd5
auth --enablemd5 --useshadow

### Lilo Configuration
lilo --location mbr


### Package Designation
### The package names, as well as the groups they are a part of can be
### found in the /RedHat/base/comps file; individual packages can be
### specified by entering their names one per line;
### groups (e.g. 'X Window System') can be specified
### by appending a "@" in front of the group name;
### e.g. '@ X Window System'
%packages
@ X Window System
@ KDE
@ Mail/WWW/News Tools
@ Networked Workstation
@ Emacs
@ Development
@ Utilities
wget

### Commands To Be Run Post-Installation
%post



I'm leaving out my post section, as it should have no effect.  If anyone is unable to reproduce the bug without the post, let me know and I'll add 
it in.  Note that passwords and IPs have been sanitized.

Laurence Berland
Comment 1 Brock Organ 2000-07-13 10:55:03 EDT
this behavior was confirmed in 6.2 ... and is fixed internally for the next
release ... thanks for submitting this report!

Note You need to log in before you can comment on or make changes to this bug.