Bug 139111 - image convertion with latex2html
Summary: image convertion with latex2html
Status: CLOSED DUPLICATE of bug 158665
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-12 23:11 UTC by Jacques Rodary
Modified: 2013-07-02 23:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 14:41:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jacques Rodary 2004-11-12 23:11:02 UTC
Description of problem:lattex2html can't convert postcrip images to
png because of:
pstoimg: Error: "/usr/bin/ppmquant -floyd 256 <
/home/jr/tmp/l2h20434/p20449.pnm | /usr/bin/pnmtopng -interlace -trans
'#ffffff'  > img6.png" failed: Mauvais descripteur de fichier

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: No problem with gif images. No problem with
latex2html tarball. It works with FC2.

Comment 1 Patrice Dumas 2004-11-30 12:50:46 UTC
run with -debug, latex2html shows that there is a segault somewhere.

Running "/usr/bin/ppmquant -floyd 256 < /tmp/l2h17175/p17188.pnm |
/usr/bin/pnmtopng -interlace -trans '#ffffff'  > img12.png"
pnmcolormap: making histogram...
pnmcolormap: 15 colors found
pnmcolormap: Image already has few enough colors (<=256).  Keeping same colors.
pnmremap: 15 colors found in colormap
pnmtopng: 15 colors found
sh: line 1: 17200 Done                    /usr/bin/ppmquant -floyd 256
</tmp/l2h17175/p17188.pnm
     17201 Segmentation fault      | /usr/bin/pnmtopng -interlace -trans
'#ffffff' >img12.png
pstoimg: Error: "/usr/bin/ppmquant -floyd 256 < /tmp/l2h17175/p17188.pnm |
/usr/bin/pnmtopng -interlace -trans '#ffffff'  > img12.png" failed: Bad file
descriptor
Debug (syswait): Finished child process: #17188
 at /usr/bin/latex2html line 4246

Error while converting image

Strangely the same command as above works from the command line:
[dumas@chapelle latex2html]$ /usr/bin/ppmquant -floyd 256 <
/tmp/l2h17175/p17188.pnm | /usr/bin/pnmtopng -interlace -trans '#ffffff'  >
img12.png
pnmcolormap: making histogram...
pnmcolormap: 15 colors found
pnmcolormap: Image already has few enough colors (<=256).  Keeping same colors.
pnmremap: 15 colors found in colormap
pnmtopng: 15 colors found


Comment 2 Jindrich Novy 2004-12-07 10:37:47 UTC
The segmentation fault is caused by buggy libpng-1.2.7. The issue can
be fixed by upgrading to libpng-1.2.8 available from:

http://people.redhat.com/jnovy/files/libpng-1.2.8-1.src.rpm

Comment 3 Patrice Dumas 2004-12-07 23:37:51 UTC
I have upgraded to rawhide libpng, libpng-1.2.8-1, it doesn't fix this
issue.

Comment 4 Rodary Jacques 2004-12-08 00:13:42 UTC
no way! upgrading doesn't fix it.

Comment 5 Jindrich Novy 2004-12-08 08:51:01 UTC
Weird, after upgrading to libpng-1.2.8 I'm not able to reproduce the
bug any more. Let me investigate it a bit more.

Comment 6 Jindrich Novy 2005-02-02 06:50:01 UTC
Could you please try netpbm-10.26-1 (now available in devel) if this
still happens with the new netpbm release?

Comment 7 Jacques Rodary 2005-02-02 10:03:30 UTC
It's OK with netpbm-10.26-1. Thanks

Comment 8 Sean A. Irvine 2005-05-02 05:23:57 UTC
I have libpng-1.2.8-1 and netpbm-10.27-1 and get:

escher[sean]:ttt> /usr/bin/pnmcrop -verbose  <p30197.pnm | /usr/bin/ppmquant
-floyd 256 | /usr/bin/pnmtopng -interlace -trans '#ffffff'  > img96.png
pnmcrop: Background color is gray70
pnmcrop: cropping 3 rows off the top
pnmcrop: cropping 1 row off the bottom
pnmcrop: cropping 1 col off the left
pnmcrop: cropping 1 col off the right
pnmcolormap: making histogram...
pnmcolormap failed, rc=11
pnmtopng: Error reading magic number from Netpbm image stream.  Most often, this
means your input file is empty.

More exact:

escher[sean]:ttt> pnmcolormap 16 <p30197.pnm
pnmcolormap: making histogram...
Segmentation fault

Do I need to somehow go back to 10.26-1 to get this to work?

Comment 9 Jacques Rodary 2005-05-30 11:40:05 UTC
Here it goes again with netpbm-10.27-3!

Comment 10 Jindrich Novy 2005-05-30 14:41:10 UTC
Ok, I'm resolving this as a duplicate of more recent bug what has more
information for this issue.

*** This bug has been marked as a duplicate of 158665 ***


Note You need to log in before you can comment on or make changes to this bug.