Bug 139122 - can't allocate partition on install even though I have 17G free space
can't allocate partition on install even though I have 17G free space
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 19:35 EST by Scott Otterson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1st auto partition error message screenshot (88.54 KB, image/jpeg)
2004-11-15 12:01 EST, Scott Otterson
no flags Details
2nd auto partition error message screenshot (95.79 KB, image/jpeg)
2004-11-15 12:02 EST, Scott Otterson
no flags Details
1st manual partition error message screenshot (96.25 KB, image/jpeg)
2004-11-15 12:02 EST, Scott Otterson
no flags Details
2nd manual partition error message screenshot (95.79 KB, image/jpeg)
2004-11-15 12:03 EST, Scott Otterson
no flags Details

  None (edit)
Description Scott Otterson 2004-11-12 19:35:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I wiped my old fc2 partition and tried to install fc3 (final release)
in the resulting 17G of freespace.  When I try to install using auto
partitioning, I get an error message saying it can't allocate a
partition (see automsg1 attachment which I'll create after I the the
email letting me do so).  When I click OK, I get the 2nd error popup
(automsg2 attachment).  

So, I tried manual partitioning (manualmsg1 attachment) shows the
partition table I see when I click manual partitioning.  When I select
the click on the free space I get a "you have not defined a root
partition" error (manualmsg2 attacment).

What can I do?

Version-Release number of selected component (if applicable):
final release of fc3

How reproducible:
Always

Steps to Reproduce:
see above
    

Additional info:
Comment 1 Jeremy Katz 2004-11-15 09:52:06 EST
Could you provide the attachment?
Comment 2 Scott Otterson 2004-11-15 12:01:06 EST
Created attachment 106719 [details]
1st auto partition error message screenshot
Comment 3 Scott Otterson 2004-11-15 12:02:03 EST
Created attachment 106720 [details]
2nd auto partition error message screenshot
Comment 4 Scott Otterson 2004-11-15 12:02:53 EST
Created attachment 106721 [details]
1st  manual partition error message screenshot
Comment 5 Scott Otterson 2004-11-15 12:03:29 EST
Created attachment 106722 [details]
2nd  manual partition error message screenshot
Comment 6 Scott Otterson 2004-11-15 12:17:01 EST
I eventually got this to work with manual partitioning.  The problem
was that there were already two primary parititions; I needed to
create three new partitions (/, /boot, swap); and only four primary
partitions were allowed.

There were two difficulties: net folklore says that swap had to be
primary, but when I finally gave up on that idea, it was not clear a
how to put both swap and swap and / in extended partitions.  I tried a
bunch of stuff and somehow it eventually worked, yielding this strange
partition table:

Minor    Start       End     Type      Filesystem  Flags
1          0.031  15850.898  primary   ntfs        boot
2      15850.898  39992.695  primary   fat32       lba
3      39997.771  40091.901  primary   ext3
4      40091.902  57231.562  extended
5      40091.933  42092.182  logical   linux-swap
6      42092.213  57231.562  logical   ext3

When I originally installed fc2, I somehow had only five partitions
but I can't retrieve how that was arranged now.

Anyway, it seems to me that there are three bugs here

1.) manual partitioning: should have been able to set this up with
only five partitions.
2.) manual partitioning: extended partitioning needs better docs
2.) automatic parititioning:  it should have been able to figure out
how to do what I did with manual partitioning, rather than printing
those cryptic error messages.
Comment 7 Chris Lumens 2005-01-27 16:00:26 EST
I know it's been a while, but do you think you could remember the partition
layout before you started doing things by hand?  I'd like to be able to
duplicate your conditions here and make sure I can reproduce this bug.  I've
been able to get the same error messages but I don't think they're related to
what you saw.
Comment 8 Scott Otterson 2005-02-10 23:57:43 EST
It was just like this:

Minor    Start       End     Type      Filesystem  Flags
1          0.031  15850.898  primary   ntfs        boot
2      15850.898  39992.695  primary   fat32       lba

with the rest of the disk space not allocated to any partition (I totally
deleted the old fc2 partition)
Comment 9 Chris Lumens 2005-02-11 10:37:21 EST
Not that it makes any difference, since the same people will still be looking at
it, but this is actually an anaconda bug.
Comment 10 Chris Lumens 2005-05-05 14:03:14 EDT
Please try fc4test3 when it is made available.  I'm no longer able to reproduce
this problem, though perhaps I just don't remember exactly what I did to see it
before.
Comment 11 Matthew Miller 2005-07-29 10:59:26 EDT
This is probably a dupe of bug #129528, and also of mysterious restricted bug
#131325.

Note You need to log in before you can comment on or make changes to this bug.