Bug 13913 - Red Hat locks up when Ethernet pipe fills
Red Hat locks up when Ethernet pipe fills
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 15:05 EDT by rgk2
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-16 17:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rgk2 2000-07-13 15:05:26 EDT
In my research, I am constantly filling up our 10 and 100 Mbps ethernet 
networks.  The problem is that Red Hat freezes up everytime I run at full 
speed and must be rebooted.  I know it's not a network card problem 
because M.S. Windows works greate with the exact same network cards.  And 
it happens on all the cards I have tried.
Comment 1 Cristian Gafton 2000-08-08 22:41:51 EDT
assigned to jakub
Comment 2 Jakub Jelinek 2000-08-09 09:11:50 EDT
Can you be a little bit more specific on which cards it was, some way to
reproduce it and why
you chose ethtool component (a utility for changing ethernet parameters on
certain Sun cards) -
this bug is most probably against the kernel component, not ethtool.
Comment 3 Dvang_1 2000-08-09 11:16:08 EDT
Which kernel are you using?  I had the same problem with RH 6.2 kernel 2.2.14,
then I upgraded to 2.2.16-3 and everything is fine now,...so far(a week so far)

-Dang
Comment 4 rgk2 2000-08-09 11:43:36 EDT
Sorry for submitting it  under the ethtool component.  I wasn't sure which
component to submit it under and that seemed the closest..
I am running kernet 2.2.14.  My system is a Dell Optiplex GX1 running a PII 450,
256 MB ram.  I use the standard ethernet card on the motherboard.  To reproduce
it, start an ethernet broadcast storm and see if your computer can recover from
it without rebooting.  
We have several ASA computers running dual 266's and uses a standard 3com 10/100
ethernet card and has the same problem. They too are running kernel 2.2.14.  
The only computer that lives is the Dell Poweredge 4300 which has 4 Xeon 550's
and a gig of ram.  It too is running kernel 2.2.14.  Unfortunately I can't get
to it's ethernet card because it can't be shut down for a while.
  You mentioned it could be a kernel problem.  We think it might be a driver
problem too.

Comment 5 Jakub Jelinek 2000-08-09 11:48:06 EDT
Yes, but a kernel driver bug is kernel bug.
Can you try 2.2.16 if it fixes the locks?
Comment 6 Alan Cox 2000-09-16 17:26:54 EDT
This certainly fits a bug that was fixed in the driver - its not a full pipe its
huge numbers of bad frames (eg collisions)

Note You need to log in before you can comment on or make changes to this bug.