Bug 139136 - incorrect $releasever after upgrade
incorrect $releasever after upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 22:21 EST by Gerard Braad
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 23:02:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Braad 2004-11-12 22:21:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Version-Release number of selected component (if applicable):
yum-2.1.11-3

Description of problem:
After upgrading the system from Fedora Core 2 to Fedora Core 3, the
systemn reports I have a Fedora 2 machine when I want to individually
want to update a package.

There seems to be something wrong with the $releasever variables set
in the yum.conf. the easy workaround for this problem is to replace
this $-variable with a hardcoded '3'. Although, this should be done
automagically.

i have not been able to reproduce it, since this would involve
updating another system or downgrading again. in the reproduce you can
see hat my actions where to produce this error.

How reproducible:
Didn't try

Steps to (re)Produce:
1. yum update yum
2. yum upgrade
3. reboot
4. yum update
    

Actual Results:
Setting up Update Process
Setting up Repo:  freshrpms
repomd.xml                100% |=========================|  843 B    00:00
Setting up Repo:  base
http://sunsite.mff.cuni.cz/pub/fedora/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://mirror.hiwaay.net/redhat/fedora/linux/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://ftp.dulug.duke.edu/pub/fedora/linux/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://mirrors.kernel.org/fedora/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
http://rpmfind.net/linux/fedora/core/2/i386/os/repodata/repomd.xml:
[Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
Cannot open/read repomd.xml file for repository: base
failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to
try.


Expected Results:
instead of
   fedora/core/2/
report of
   fedora/core/3/

Additional info:
the system does report it is a Fedora Core 3 release

# cat /etc/fedora-release
Fedora Core release 3 (Heidelberg)

the line about freshrpms (additional repo) was just a test. without
it, the system reports the same problem.
Comment 1 Seth Vidal 2004-11-12 22:24:33 EST
rpm -q fedora-release



Comment 2 Gerard Braad 2004-11-12 23:02:56 EST
just in case i did do a:
  rpm -Uvh fedora-release

with no error (only already installed)

but i haven't thought about the possibilty of there being two
packages. this query namely results with the following information:
  fedora-release-2-4
  fedora-release-3-8

removing one with
  rpm -e fedora-release-2-4

resolved the problem.

but how can this happen??? to be honest, i had seen this two packages
problem before on upgrading redhat versions. but it mainly only
happens when you have /var on a different disc when upgrading with
cd's. but this was a live upgrade.

Note You need to log in before you can comment on or make changes to this bug.