Bug 139143 - Boot Failure after upgrade FC2 to FC3
Boot Failure after upgrade FC2 to FC3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 00:01 EST by Jerry
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 11:55:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My fstab for reference. (839 bytes, text/plain)
2004-11-13 18:42 EST, Jerry
no flags Details

  None (edit)
Description Jerry 2004-11-13 00:01:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I just ran an upgrade from FC2 to FC3.  Fails to boot with this
message right after nash

mounting root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempting to kill init!

Can boot previous FC2 kernel and all functions OK.

Tried a mkinitrd to see if that would help, did not help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot
2.at grub menu select latest kernel
3.
    

Actual Results:  Fails to boot as described

Additional info:
Comment 1 Jerry 2004-11-13 00:14:23 EST
I am using a single SATA drive.  I have also noticed that running
lsusb hangs and I can not kill -9 the process.  Running Hardware
Browser also just hangs.  (System keeps running, the apps hang).  I
can not locate my USB memory stick which worked fine on FC2

This is when I boot with kernel-2.6.8-1.521smp.  Kernel itself seems
stable.

A udev issue?
Comment 2 Jerry 2004-11-13 18:35:02 EST
Here are messages when trying to boot with kernel 2.6.9-1.667,
recorded by hand:

Red Hat nash version 4.1.18 Starting
Mounted /proc filesystem
Mounting sysfs
Creating /dev
Starting udev
Loading jdb.ko module
Loading ext3.ko module
Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext3
mount: error 2 mounting none
Switching to new root
Switchroot: mount failed: 2 2
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

The problem seems to start at Creating root device.  I am not expert
enough to understand this stage of boot, but it works fine with kernel
2.6.8-1.521.

Comment 3 Jerry 2004-11-13 18:42:11 EST
Created attachment 106655 [details]
My fstab for reference.
Comment 4 Jeremy Katz 2004-11-15 17:25:10 EST
If you boot into rescue mode, can you get /etc/modprobe.conf from your
install?
Comment 5 Jerry 2004-11-15 20:46:38 EST
I got impatient and did a clean install yesterday and all works except
 for a conflict between my usb memory stick and HP
printer/scanner/memory card reader.

However here is the modprobe.conf.

alias eth0 e100
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Hope this gives some clues.  
Comment 6 Jerry 2004-11-15 20:49:42 EST
Forgot to mention that Hardware Browser and lsusb both go to never
never land when I try to run them.  I end up with zombie processes for
those.

Still that way after the clean install.  I think this is the usb
conflict with the psc printer (HP psc2175)
Comment 7 Jeremy Katz 2004-11-16 11:55:38 EST
Unfortunately, by doing a fresh install, you've completely wiped out
any useful information for me to reproduce the problem :(
Comment 8 Jerry 2004-11-17 00:04:52 EST
Sorry about that.  I have to rely on this one computer.  If the clean
FC3 did not work I was going to go back to FC2 and try again.  I have
a second hardrive planned.  If I can load up FC2 on one and FC3 clean
on the other then I can experiment with running the upgrade process. 
Does this seem feasible?
Comment 9 Jerry 2004-11-17 02:08:25 EST
Jeremy,

Need to reopen this one.  I just upgarded to kernel-2.6.9-1.678_FC3smp
and it won't boot and I get the exact same behavior.  So I will gladly
help you investigate.

Jerry
Comment 10 Jamie 2005-06-23 06:07:47 EDT
I have exactly this same problem except for two things:
1. I upgraded from RH9 to FC3
2. I am not even able to boot in rescue mode.

Let me know if I can help gather info for this.

Jamie
Comment 11 Jamie 2005-06-23 17:08:13 EDT
I rebooted from the install disc with all USB drives (one DVD writer and one 
external 140G drive) and was able to do a fresh install (prior to that I was 
not even able to boot from the install disc -- a system halt would cause the 
install to hang). Since I had all required data backed up, I also selected to 
format the partition (EXT3). Everything seems okay now.

I also noticed (while having the orig. problem) that perhaps the fstabs file 
was not configured properly for FC3 (the drive designations had HDAn and now 
they show SDAn... could this have caused the problem?

Note You need to log in before you can comment on or make changes to this bug.