Bug 1391574 - [abrt] abiword: AP_UnixApp::catchSignals(int)(): abiword killed by SIGABRT
Summary: [abrt] abiword: AP_UnixApp::catchSignals(int)(): abiword killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8c6c0465f8d6d21becc3e7c478c...
: 1398346 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-03 15:04 UTC by Filipe Rosset
Modified: 2016-12-20 17:21 UTC (History)
4 users (show)

Fixed In Version: abiword-3.0.2-3.fc24 abiword-3.0.2-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 06:23:39 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (35.74 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: cgroup (242 bytes, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: core_backtrace (4.49 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: dso_list (17.76 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: environ (1.86 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: limits (1.29 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: maps (85.54 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: mountinfo (3.51 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: namespaces (102 bytes, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: open_fds (876 bytes, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: proc_pid_status (1.10 KB, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details
File: var_log_messages (298 bytes, text/plain)
2016-11-03 15:05 UTC, Filipe Rosset
no flags Details

Description Filipe Rosset 2016-11-03 15:04:54 UTC
Description of problem:
try to open abiword on gnome wayland session

Version-Release number of selected component:
abiword-3.0.1-12.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        abiword
crash_function: AP_UnixApp::catchSignals(int)
executable:     /usr/bin/abiword
global_pid:     3012
kernel:         4.8.6-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #2 AP_UnixApp::catchSignals(int) at ap_UnixApp.cpp:1569
 #3 signalWrapper(int) at ap_UnixApp.cpp:1512

Potential duplicate: bug 1272704

Comment 1 Filipe Rosset 2016-11-03 15:05:02 UTC
Created attachment 1217034 [details]
File: backtrace

Comment 2 Filipe Rosset 2016-11-03 15:05:04 UTC
Created attachment 1217035 [details]
File: cgroup

Comment 3 Filipe Rosset 2016-11-03 15:05:06 UTC
Created attachment 1217036 [details]
File: core_backtrace

Comment 4 Filipe Rosset 2016-11-03 15:05:08 UTC
Created attachment 1217037 [details]
File: dso_list

Comment 5 Filipe Rosset 2016-11-03 15:05:11 UTC
Created attachment 1217038 [details]
File: environ

Comment 6 Filipe Rosset 2016-11-03 15:05:13 UTC
Created attachment 1217039 [details]
File: limits

Comment 7 Filipe Rosset 2016-11-03 15:05:16 UTC
Created attachment 1217040 [details]
File: maps

Comment 8 Filipe Rosset 2016-11-03 15:05:18 UTC
Created attachment 1217041 [details]
File: mountinfo

Comment 9 Filipe Rosset 2016-11-03 15:05:20 UTC
Created attachment 1217042 [details]
File: namespaces

Comment 10 Filipe Rosset 2016-11-03 15:05:22 UTC
Created attachment 1217043 [details]
File: open_fds

Comment 11 Filipe Rosset 2016-11-03 15:05:24 UTC
Created attachment 1217045 [details]
File: proc_pid_status

Comment 12 Filipe Rosset 2016-11-03 15:05:26 UTC
Created attachment 1217046 [details]
File: var_log_messages

Comment 13 Nuno Dias 2016-11-24 13:56:25 UTC
*** Bug 1398346 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2016-11-30 02:37:46 UTC
abiword-3.0.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d2e43d0928

Comment 15 Fedora Update System 2016-11-30 02:38:32 UTC
abiword-3.0.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea95a6a39f

Comment 16 Fedora Update System 2016-11-30 08:18:40 UTC
abiword-3.0.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-673afe7e75

Comment 17 Fedora Update System 2016-11-30 08:19:24 UTC
abiword-3.0.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-564152f164

Comment 18 Fedora Update System 2016-12-03 04:33:14 UTC
abiword-3.0.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-564152f164

Comment 19 Fedora Update System 2016-12-03 05:40:13 UTC
abiword-3.0.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-673afe7e75

Comment 20 Fedora Update System 2016-12-08 04:29:05 UTC
abiword-3.0.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab

Comment 21 Fedora Update System 2016-12-08 04:30:00 UTC
abiword-3.0.2-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57

Comment 22 Fedora Update System 2016-12-08 19:24:32 UTC
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab

Comment 23 Fedora Update System 2016-12-08 19:26:27 UTC
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57

Comment 24 Фукидид 2016-12-18 18:04:17 UTC
Similar problem has been detected:

Opened DOCX file in Thunar.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        abiword '/home/user/\xd0\x94\xd0\xb0\xd0\xba\xd1\x83\xd0\xbc\xd1\x8d\xd0\xbd\xd1\x82\xd1\x8b/\xd0\x9c\xd0\xb0\xd0\xbc\xd0\xb5/\xd0\xb7\xd0\xb0\xd0\xba\xd0\xb0\xd0\xb7 181-1.docx'
crash_function: AP_UnixApp::catchSignals(int)
executable:     /usr/bin/abiword
global_pid:     9244
kernel:         4.8.14-300.fc25.x86_64
package:        abiword-3.0.1-12.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         abiword killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 Fedora Update System 2016-12-20 06:23:39 UTC
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2016-12-20 17:21:22 UTC
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.