Bug 139162 - Creative Labs [SB Live! Value] EMU10k1X detected but no sound
Creative Labs [SB Live! Value] EMU10k1X detected but no sound
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-soundcard (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 07:06 EST by Dirk Gfroerer
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 09:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Gfroerer 2004-11-13 07:06:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
My Dell Dimension 4550 is equipped with a Creative Labs [SB Live!
Value] EMU10k1X soundcard. I'm not really sure if this card is
supported (due to the chip being an EMU10k1X) or not. At least it
doesn't work in Taroon only in Windows XP. system-config-soundcard
however detectes the sound card (along with the onboard ICH-4
soundchip) but I cannot hear the testsound.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.10-1

How reproducible:
Always

Steps to Reproduce:
1. Start system-config-soundcard EMU10k1X appears as primary sound card.
2. Play test sound

    

Actual Results:  No sound can be heard.

Expected Results:  Sound can be heard or card is put on blacklist.

Additional info:

output of lspci -v

02:01.0 Multimedia audio controller: Creative Labs [SB Live! Value]
EMU10k1X
        Subsystem: Creative Labs: Unknown device 1003
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at dce0 [size=32]
        Capabilities: [dc] Power Management version 2

02:01.1 Input device controller: Creative Labs [SB Live! Value] Input
device controller
        Subsystem: Creative Labs: Unknown device 1003
        Flags: bus master, medium devsel, latency 64
        I/O ports at dcd8 [size=8]
        Capabilities: [dc] Power Management version 2
Comment 1 kevin 2005-01-19 02:33:52 EST
Are you sure you installed alsa with the snd-emu10k1x module and NOT
the snd-emu10k1 module? With a similar Dell SBLive Value card on a
Dimension 8200, I was experiencing the same problems when using module
snd-emu10k1. Switching over to the snd-emu10k1x module specified for
the OEM Sound Blaster PCI X (Dell OEM) SB0200 card fixed the issue.
Comment 2 Dirk Gfroerer 2005-01-19 02:48:52 EST
That's the point I was trying to make. It is a EMU10k1X so it does not
work with the emu10k1 module. system-config-sound however is not aware
of this issue and tries to load the emu10k1 module which fails.
Since the emu10k1x module is not provided with Nahant (with the
2.6.9-1.675_EL kernel), system-config-sound should either list the
card as not being supported or Red Hat should include the emu10k1x
module; from my personal point of view of course.
Comment 3 Jonathan Stanford 2005-05-13 09:52:17 EDT
I've ran into a simular problem, and possibly stumbled onto a clue.  using
snd-emu10k1 the sound does not come out the "front" channels... but rather the
"rear" channels. very odd, but i'd imagion it's not too hard to fix.
Comment 4 Jonathan Stanford 2005-05-30 11:40:12 EDT
(In reply to comment #3)
> I've ran into a simular problem, and possibly stumbled onto a clue.  using
> snd-emu10k1 the sound does not come out the "front" channels... but rather the
> "rear" channels. very odd, but i'd imagion it's not too hard to fix.

the latest ALSA driver release (1.0.9) fixes this problem
Comment 5 Martin Stransky 2005-06-29 08:35:02 EDT
Can anybody confirm funcionality of new ALSA driver on RHEL4?
It has a driver for emu10k1x and RHEL4&s-c-s may work with it...
Comment 6 Martin Stransky 2005-08-29 09:50:03 EDT
We didn't upgrade the drivers in RHEL, it's too risky, so closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.