Bug 139168 - Linksys WPC11 doesn't work
Linksys WPC11 doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-13 10:30 EST by Wayne Walker
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Walker 2004-11-13 10:30:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Linksys WPC11 ver. 3 (Prism 2) is recognized.  orinoco driver loads,
but card doesn't connect to any of the 3 WAPs here local.

Card was used on a daily basis with multiple WAPs with no problem
until FC3 upgrade.

Other PCMCIA/CardBus cards work fine (firewire and wired ethernet)

iwconfig shows wireless extensions for the card, but doesn't connect.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Insert WPC11
2. Wait a few seconds for module loading
3. lsmod and iwconfig
    

Actual Results:  orinoco_cs              9545  1 
orinoco                47053  1 orinoco_cs
hermes                  7617  2 orinoco_cs,orinoco
ds                     16965  5 orinoco_cs
yenta_socket           18753  1 
pcmcia_core            59913  3 orinoco_cs,ds,yenta_socket

eth0      IEEE 802.11-DS  ESSID:""  Nickname:"Prism  I"
          Mode:Managed  Access Point: 00:00:00:00:00:00   Bit
Rate:11Mb/s   
          Tx-Power=15 dBm   Sensitivity:1/3  
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=-68 dBm  Noise level=-122 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0



Expected Results:  an access point MAC  showing that we're connected.
 There are three WAPs here...

Additional info:

Thinkpad 600X
Comment 1 Markus Berndt 2004-11-16 15:17:25 EST
I've had a similar problem. During the installation of FC3, the line 

alias orinoco_cs eth1 

was put in /etc/modprobe.conf

Removing this line solved the problem. 
Comment 2 Wayne Walker 2004-11-17 13:13:45 EST
I reloaded from scratch, and upgraded to the recently available -678
kernel.   Problem gone.  Don't know whether it was the kernel or the
fresh install.
Comment 3 Dave Jones 2005-07-15 14:30:29 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Wayne Walker 2005-07-15 16:27:16 EDT
Sorry, new notebook with built in wireless.  Don't have the WPC-11 any longer. 
I can't test it.  When I went to FC4t2 on that notebook the problem did Not
reoccur.

Note You need to log in before you can comment on or make changes to this bug.