Bug 139213 - Media check fails for FC3 iso 2 & 3
Summary: Media check fails for FC3 iso 2 & 3
Status: CLOSED DUPLICATE of bug 131858
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 04:15 UTC by Normand Robert
Modified: 2015-01-04 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 19:33:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Normand Robert 2004-11-14 04:15:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3)
Gecko/20040913

Description of problem:
Duplicate of 137217 ?

I get media check failures using FC3 for these disks burned with
"uptodate" RH9

FC3-i386-disc2.iso
FC3-i386-disc3.iso

MD5SUM's for all 5 discs (1-4 + rescue) agree with values posted on
mirror site.

Reburned discs 2 and 3 at slower speed with better media in RH9

cdrecord  -v speed=12 dev=1,0,0 ~robert/FC3-i386-disc2.iso

and obtained errors again at the very end of the media check process
as indicated by the progress bar. My RH9 system burns CD extremely
reliably (~1 coaster/80) so I will ignore the failures and try to
install anyways.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Burn MD5SUM checked FC3 ISO images on patched RH 9 system using   
   cdrecord -v speed=12 dev=1,0,0 ~robert/FC3-i386-disc2.iso

2. Insert ISO 1 in cd tray and boot system from ISO 1.

3. Run media check on 1,2,3,4 and rescue.
   
    

Actual Results:  ISO 2,3 fail media check at the very end of media
check as indicated by the progress bar.

Expected Results:  Media check to pass for all FC3 ISO images.

Additional info:

Comment 1 Jeremy Katz 2004-11-15 15:13:32 UTC
This is caused by a kernel bug.

Comment 2 Need Real Name 2004-12-05 23:33:47 UTC
The same thing is happening to me, only with the x86_64 ISOs.
md5sum reports correct checksums on all my ISO images before I burn
them, but the FC3 installer rejects all four of the CDs.
I burned them multiple times at various speeds down to 4x on
48x-certified media, but it made no difference.

Curiously, 3 out of 4 of the i386 FC3 ISOs I burned on the
same burners passed the test. (Disc 2 failed.)

Is it safe to use these CDs to install?

Comment 3 Normand Robert 2004-12-06 04:18:22 UTC
I was able to install without any problems.

Comment 4 O.R.Senthil Kumaran 2005-01-14 20:08:11 UTC
Using linux ide=nodma during install will resolve this and will not
give this Media Check failure issue (with CD2 and CD3 isos)

I faced the same problem with: _NEC CD-RW NR-9100A  Drive.
which could not work properly with dma during Install.

_NEC CD-RW NR-9100A  should be added to the list of nodma blacklist.
(Is there any Bug# which is collecting the devices which has problems
with DMA)


[ors@h1c661s ~]$ cat /proc/ide/hdc/model
_NEC CD-RW NR-9100A

[ors@h1c661s ~]$ dmesg | grep CD
hdc: _NEC CD-RW NR-9100A, ATAPI CD/DVD-ROM drive
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
[ors@h1c661s ~]$


Comment 5 Joe Dupre 2005-07-14 05:25:41 UTC
I had same problem on a Sony laptop w/ Toshiba DVD-RW SD-R6012.
Setting ide=nodma resulted in passing the media check. 

Comment 6 Joe Dupre 2005-07-14 05:28:54 UTC
I should have noted above that all of my FC4 CD images were failing until I 
added the ide=nodma switch.

Comment 7 Dave Jones 2005-07-15 19:54:10 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 8 Normand Robert 2005-07-15 23:36:52 UTC
Does this mean that the iso distribution itself has been updated? 

Comment 9 Dave Jones 2005-07-15 23:51:02 UTC
no, the ISOs never get respun.  Sometimes a new boot.iso is created, but not always.

For this bug, after an installation, and update to the new kernel, running the
media check from the anaconda-runtime package should now work.

I know its a little backwards to do the check /after/ you've installed, but this
should also mean that FC5 and onwards should have this fixed. Hopefully.


Comment 10 Dave Jones 2005-12-07 19:33:17 UTC

*** This bug has been marked as a duplicate of 131858 ***


Note You need to log in before you can comment on or make changes to this bug.