Bug 139227 - Hald crashes when there are many partitions
Hald crashes when there are many partitions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 02:48 EST by Eric Yeo
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4.2-1.FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 18:09:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from "hald --verbose=yes --daemon=no" (71.25 KB, text/plain)
2004-11-14 02:50 EST, Eric Yeo
no flags Details

  None (edit)
Description Eric Yeo 2004-11-14 02:48:10 EST
Description of problem:

I recently upgrade from FC2 to FC3. The daemon hald keeps crashing
right after startup.

Version-Release number of selected component (if applicable):

hal-0.4.0-10

How reproducible:

Very reproducible. I am not sure what the minimum number of disk
partitions that can cause this problem but this is the output of "df"

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda16              988212    422624    515388  46% /
/dev/hda7              5036284   3402644   1377808  72% /home
none                    517452         0    517452   0% /dev/shm
/dev/hda10             1035660     72548    910504   8% /tmp
/dev/hda6              5036284   3675468   1104984  77% /usr
/dev/hda5              5036284   3036936   1743516  64% /usr/local
/dev/hda11             4830136   3680612   1100608  77% /usr/oracle
/dev/hda8              3020140    695024   2171700  25% /var
/dev/hda13             4814936   2443792   2322228  52% /var/cdr
/dev/hda12             5771468   4386544   1326288  77% /public
/dev/hda14            14639936  11287712   3205632  78% /vmware
/dev/hda15             3850292   3310888    539404  86% /usr/local/nwn
/dev/hdc               2408604   2408604         0 100% /media/cdrecorder


Steps to Reproduce:
1. service haldaemon start
2. Or alternatively run "/usr/sbin/hald --verbose=yes --daemon=no
  
Actual results:

If I run hald with verbose flag, I get a lot of output with the last lines

18:43:26.502 [I] linux/volume_id/volume_id.c:574: to many partitions
18:43:26.502 [I] linux/block_class_device.c:1301: Number of partitions
= 17

It is crashed with "Segmentation fault"

Expected results:

Hald should not crash.

Additional info:
Comment 1 Eric Yeo 2004-11-14 02:50:21 EST
Created attachment 106663 [details]
Output from "hald --verbose=yes --daemon=no"
Comment 2 David Zeuthen 2004-11-15 14:33:21 EST
This looks like a bug, yeah. I'll try to reproduce it and then fix it.
Thanks, David.
Comment 3 David Zeuthen 2004-11-16 17:05:26 EST
Should be fixed with these RPM's; please test

 http://people.redhat.com/davidz/hal-testing/

Thanks,
David
Comment 4 Eric Yeo 2004-11-17 20:42:48 EST
I have installed the RPMs and it does not crash any more. Thank you.

Note You need to log in before you can comment on or make changes to this bug.