Bug 139228 - no scrolling support with synaptics
Summary: no scrolling support with synaptics
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: synaptics   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 08:18 UTC by Justin Georgeson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 13:40:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Georgeson 2004-11-14 08:18:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
This touchpad supports treating the right and bottom edges as
scrolling buttons. It works in Windows and Ubuntu, so I know the
hardware works. This is my current config

Section "InputDevice"
        Identifier    "Synaptics Mouse"
        Driver        "synaptics"
        Option        "Device"        "/dev/psaux"
        Option        "Protocol"      "auto-dev"
        Option        "LeftEdge"      "1700"
        Option        "RightEdge"     "5300"
        Option        "TopEdge"       "1700"
        Option        "BottomEdge"    "4200"
        Option        "FingerLow"     "25"
        Option        "FingerHigh"    "30"
        Option        "MaxTapTime"    "180"
        Option        "MaxTapMove"    "220"
        Option          "UpDownScrolling"       "on"
        Option        "VertScrollDelta" "100"
        Option        "MinSpeed"      "0.06"
        Option        "MaxSpeed"      "0.12"
        Option        "AccelFactor"     "0.0010"
EndSection


Version-Release number of selected component (if applicable):
synaptics0.13.5-5

How reproducible:
Always

Steps to Reproduce:
1. Start an application with a vertical scrollbar
2. Drag finger on rightmost edge of touchpad to scroll

    

Actual Results:  mouse pointer moves up/down

Expected Results:  application window should scroll up/down

Additional info:

Comment 1 Justin Georgeson 2004-11-15 00:51:23 UTC
Well, it seems to be working now. I switched the device to
/dev/input/mice (which is what it started off as, before I changed it
to match the README/INSTALL documentation). 

Comment 2 Paul Nasrat 2004-11-15 13:40:30 UTC
/dev/input/mice is correct


Note You need to log in before you can comment on or make changes to this bug.