Bug 139270 - FC3 does not see FC2 partition for upgrade
FC3 does not see FC2 partition for upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 13:53 EST by Robin Atwood
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 13:24:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc3 anaconda.log when it does not recognize fc2 (5.15 KB, text/plain)
2004-11-15 14:17 EST, Ilkka Tengvall
no flags Details
anaconda log after FC installation search (5.05 KB, text/plain)
2004-11-15 15:17 EST, Robin Atwood
no flags Details

  None (edit)
Description Robin Atwood 2004-11-14 13:53:57 EST
Description of problem: 
I am installing FC3 from the DVD iso on a hard disk. When anaconda 
starts and tries to detect existing FC systems it finds none. I have 
two FC2 partitions, one is a clone of the other (FWIW, with different  
labels). Using the DVD in rescue mode detects both partitions. I have 
fscked and rebuilt the RPM database. What signature is anaconda 
looking for? 
 
Version-Release number of selected component (if applicable): 
FC3 anaconda 
 
How reproducible: 
every time 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
No upgrade available 
 
Expected results: 
 
 
Additional info:
Comment 1 Ilkka Tengvall 2004-11-14 14:29:49 EST
Same here, my old distro is FC2 upgraded from FC1. Anaconda does not
find previous installation, I also tried with boot option "linux
upgradeany" which I found from devel lists. There is no complaints in
logs appearing on virtual console. Just plain "moving (1) to step
installtype", no errors.

FC2 is up-to-date version, updated latest today with apt-get.


Here is some info about the system:

# cat /etc/fstab | grep -v '^#\|^ .*\|^$'
LABEL=/                 /                       ext3    defaults     
  1 1
LABEL=/boot             /boot                   ext3    defaults     
  1 2
LABEL=/home             /home                   ext3    defaults     
  1 2
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /proc                   proc    defaults     
  0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
none                    /sys                    sysfs   defaults     
  0 0
LABEL=/var              /var                    ext3    defaults     
  1 2
/dev/hda6               swap                    swap    defaults     
  0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0

# fdisk -l /dev/hda

Disk /dev/hda: 203.9 GB, 203928109056 bytes
255 heads, 63 sectors/track, 24792 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1           7       56196   83  Linux
/dev/hda2   *           8         646     5132767+   b  W95 FAT32
/dev/hda3             647        9729    72959197+   f  W95 Ext'd (LBA)
/dev/hda5             647        3257    20972826    b  W95 FAT32
/dev/hda6            3258        3382     1004031   82  Linux swap
/dev/hda7            3383        4130     6008278+  83  Linux
/dev/hda8            4131        4255     1004031   83  Linux
/dev/hda9            4256       24792   164963421   83  Linux

# e2label /dev/hda1;e2label /dev/hda7;e2label /dev/hda8;e2label /dev/hda9 

/boot
/
/var
/home


Comment 2 Ilkka Tengvall 2004-11-14 15:36:59 EST
ok, now that I briefly took a glimpse at anaconda sources
(getRedHatReleaseString), I assume you also want to know my system has
the following stuff:

$ rpm -q fedora-release
fedora-release-2-4

$ ls -l /etc/*-release
-rw-r--r--  1 root root 33 May 11  2004 /etc/fedora-release
lrwxrwxrwx  1 root root 14 Jul  5 12:16 /etc/redhat-release ->
fedora-release

$ cat /etc/redhat-release 
Fedora Core release 2 (Tettnang)

Comment 3 Jeremy Katz 2004-11-15 10:25:35 EST
Can you switch to tty2 and grab /tmp/anaconda.log and attach it?
Comment 4 Ilkka Tengvall 2004-11-15 14:17:50 EST
Created attachment 106743 [details]
fc3 anaconda.log when it does not recognize fc2

this is the log
Comment 5 Robin Atwood 2004-11-15 15:17:21 EST
Created attachment 106750 [details]
anaconda log after FC installation search
Comment 6 Jeremy Katz 2004-11-15 17:24:02 EST
Does booting with 'linux upgradeany' help at all?
Comment 7 Robin Atwood 2004-11-15 18:47:12 EST
Yes that fixed the problem. However, both partitions were listed as 
'Unknown Linux systems'. What is install looking for that is missing? 
 
Comment 8 Jeremy Katz 2004-11-15 21:15:39 EST
That means there's something that's not liked about the formatting of
the /etc/redhat-release file.  rpm -V fedora-release might show that
it's modified.
Comment 9 Ilkka Tengvall 2004-11-16 03:39:01 EST
For me it did not make any difference. Still not finding the
partitions. I also tried rpm -e fedora-release, apt-get install
fedora-release, and tried the install. no difference. I get this error:

$ rpm -V fedora-release
/etc/security/selinux/file_contexts: No such file or directory

but it is some other error, probably in packaging of fedora-release rpm.

I think I changed the hard drive to bigger one at some point. So it is
not the original install, but I have copied either the partitions (dd)
or the contents of partitions (cp) from old disk to new disk. Could
there be some problem with that?

I also tried adding boot flags to linux partitions, but no help, so I
removed those again. BTW, I can mount those fc2 hdd partitions
manually from tty2 from install cd linux no problem.
Comment 10 Robin Atwood 2004-11-16 13:16:24 EST
[root@opal tmp]# rpm -V fedora-release 
S.5....T    /etc/fedora-release 
....L...    /etc/redhat-release 
 
This seems to indicate problems. I re-installed the original rpm but 
with no change. 
Comment 11 Jeremy Katz 2004-11-16 13:24:36 EST
Sounds like things are working as expected (fedora-release is a config
file, so rpm won't replace it by default)
Comment 12 Robin Atwood 2004-11-16 14:51:15 EST
I did an rpm --force of the FC2 fedora-release on both partitions and 
both are now recognised. :-)) 
 
Comment 13 Ilkka Tengvall 2004-11-17 02:13:17 EST
Never worked for me, so I just used apt-get dist-upgrade. It worked ok.

Note You need to log in before you can comment on or make changes to this bug.