Bug 139271 - No match for USB device: HP DESKJET 3820
No match for USB device: HP DESKJET 3820
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 14:21 EST by Dawid Gajownik
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 06:06:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/share/foomatic/db/source/printer/HP-DeskJet_3820.xml (1.37 KB, text/plain)
2004-11-15 11:34 EST, Tim Waugh
no flags Details
s-c-p screenshot (319.91 KB, image/png)
2004-11-15 14:09 EST, Dawid Gajownik
no flags Details

  None (edit)
Description Dawid Gajownik 2004-11-14 14:21:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20040927

Description of problem:
I run system-config-printer and saw such a message:

[root@X etc]# system-config-printer
No match for USB device:
  mfr "HEWLETT-PACKARD"
  model "DESKJET 3820"
  desc "Hewlett-Packard DeskJet 3820"
  cmdset "MLC,PCL,PML"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Guessing ID HP-DeskJet_3820 for match

Nevertheless, printer works OK. I was really impressed - I run s-c-p
and without changing anything everything was set up correctly. Easier
than in Windows :D

Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. Run s-c-p with HP DJ3820 printer pluged in to your computer ;-)
Comment 1 Tim Waugh 2004-11-15 09:35:58 EST
Thanks for the report.

Fixed in CVS upstream.  Fixed in Fedora development CVS.
Comment 2 Tim Waugh 2004-11-15 11:34:31 EST
Created attachment 106716 [details]
/usr/share/foomatic/db/source/printer/HP-DeskJet_3820.xml

Please save this attachment as:

/usr/share/foomatic/db/source/printer/HP-DeskJet_3820.xml

and see if the printer model is now automatically selected when you run
system-config-printer.
Comment 3 Dawid Gajownik 2004-11-15 14:09:43 EST
Created attachment 106740 [details]
s-c-p screenshot

Well, I removed all printers from the list, copied the file to the appropriate
place and run once again s-c-p. It seemed to be all right except one
unimportant thing - in the printer's name there was additional number 2 at the
end (identically as after instalation).

I removed the printer once again, clicked Add, changed name and clicked several
times next, cause everything was set up correctly :D

BTW Why some files in /usr/share/foomatic/db/source/printer have chmod 755 and
other ones 644? Do they really need to be executabled?
Comment 4 Tim Waugh 2004-11-16 06:06:21 EST
Great, thanks for testing.  The queue name is decided by
hal-cups-utils I think.

I've fixed the file mode issue in CVS too.
Comment 5 Dawid Gajownik 2004-11-16 12:04:20 EST
> I've fixed the file mode issue in CVS too.
Thanks :)

Note You need to log in before you can comment on or make changes to this bug.