Bug 1392916 - sssd failes to start after update
Summary: sssd failes to start after update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sssd
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jakub Hrozek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-08 13:19 UTC by Torsten
Modified: 2020-05-02 18:32 UTC (History)
9 users (show)

Fixed In Version: sssd-1.14.2-2.fc23 sssd-1.14.2-2.fc25 sssd-1.14.2-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-17 00:23:41 UTC
Type: Bug


Attachments (Terms of Use)
Output from journalctl -u sssd (6.09 KB, text/x-vhdl)
2016-11-08 13:19 UTC, Torsten
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 4265 0 None None None 2020-05-02 18:32:46 UTC

Description Torsten 2016-11-08 13:19:19 UTC
Created attachment 1218521 [details]
Output from journalctl -u sssd

Description of problem:
Fresh install of Fedora 24 is setup with Enterprise Login against AD.
It works just fine - even after a reboot.
After an update (and reboot) it fails to start.
At login I'm promted to go through the Enterprise Setup again -
this time I don't have to provide AD admin account, but it
doesn't fix the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Fresh install failed friday but having fiddled with sssd.conf and other
config settings, I decided to start fresh monday.
This time I did the install made sure login worked (also after reboot)
did the "dnf update" and again sssd fails to start.

Steps to Reproduce:
1. Install Fedora 24 from DVD/USB - choose Enterprise Login
2. dnf update
3.

Actual results:
sssd stops working

Expected results:
Login via sssd should continue to work.

Additional info:
Output from
journalctl -u sssd
http://pastebin.com/hwnqqPRs

Using etckeeper - some git diff info:
http://pastebin.com/fKuKNZqQ

Comment 1 Lukas Slebodnik 2016-11-08 13:26:14 UTC
journalctl output is not useful by default for sssd.
Please follow https://fedorahosted.org/sssd/wiki/Troubleshooting

Comment 2 Torsten 2016-11-08 14:18:19 UTC
Increased the debug level and restarted sssd.
Looking through the /var/log/sssd/sssd.log
There seemed to be a line for each AD user (a lot!)
I also noticed some mention of DB, so I went ahead
and deleted the cache-files under /var/lib/sss/db
This seemed to do the trick sssd could now start -
and after a reboot, I could login.

Maybe You can close this one, but I don't think a system upgrade
should make sssd fail to restart.

From /var/log/sssd/sssd.log (after failed restart of sssd)
----
(Tue Nov  8 14:48:53 2016) [sssd] [server_setup] (0x0400): CONFDB: /var/lib/sss/db/config.ldb
(Tue Nov  8 14:48:53 2016) [sssd] [sss_names_init_from_args] (0x0100): Using re [(((?P<domain>[^\\]+)\\(?P<name>.+$))|((?P<name>[^@]+)@(?P<domain>.+$))|(^(?P<name>[^@\\]+)$))].
(Tue Nov  8 14:48:53 2016) [sssd] [sss_fqnames_init] (0x0100): Using fq format [%1$s@%2$s].
(Tue Nov  8 14:48:53 2016) [sssd] [sysdb_domain_init_internal] (0x0200): DB File for uni.au.dk: /var/lib/sss/db/cache_uni.au.dk.ldb
(Tue Nov  8 14:48:53 2016) [sssd] [sysdb_domain_init_internal] (0x0200): Timestamp file for uni.au.dk: /var/lib/sss/db/timestamps_uni.au.dk.ldb
(Tue Nov  8 14:48:53 2016) [sssd] [ldb] (0x0400): asq: Unable to register control with rootdse!
(Tue Nov  8 14:48:53 2016) [sssd] [sysdb_domain_cache_upgrade] (0x0100): Upgrading DB [uni.au.dk] from version: 0.17
(Tue Nov  8 14:48:53 2016) [sssd] [commence_upgrade] (0x0020): UPGRADING DB TO VERSION 0.18

Comment 3 Lukas Slebodnik 2016-11-08 15:00:05 UTC
It's difficult to say from log file but it could be a duplicate of upstream bug.
https://fedorahosted.org/sssd/ticket/3232

How big files were in /var/lib/sss/db/ ?

Comment 4 Torsten 2016-11-08 17:21:18 UTC
The original files, I don't know - they are gone.

This is what I have now:
# ls -lht /var/lib/sss/db/
total 31M
-rw-------. 1 root root 3,5K Nov  8 18:05 ccache_UNI.AU.DK
-rw-------. 1 root root  27M Nov  8 18:05 cache_uni.au.dk.ldb
-rw-------. 1 root root 1,6M Nov  8 18:05 timestamps_uni.au.dk.ldb
-rw-------. 1 root root 1,3M Nov  8 17:49 config.ldb
-rw-------. 1 root root 1,3M Nov  8 14:59 sssd.ldb

Comment 5 Lukas Slebodnik 2016-11-08 20:26:50 UTC
(In reply to Torsten from comment #4)
> The original files, I don't know - they are gone.
> 
> This is what I have now:
> # ls -lht /var/lib/sss/db/
> total 31M
> -rw-------. 1 root root 3,5K Nov  8 18:05 ccache_UNI.AU.DK
> -rw-------. 1 root root  27M Nov  8 18:05 cache_uni.au.dk.ldb
It could take some time to upgrade 27 MiB cache.

I can confirm you hit upstream bug https://fedorahosted.org/sssd/ticket/3232

I am so sorry for inconveniences. The bug is fixed in upstream.
and you already found a workaround.
rm -f /var/lib/sss/db/cache_*

Comment 6 Lukas Slebodnik 2016-11-10 12:10:06 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3232

Comment 7 Fedora Update System 2016-12-13 20:07:50 UTC
sssd-1.14.2-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-66bc868b6e

Comment 8 Fedora Update System 2016-12-13 20:09:55 UTC
sssd-1.14.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b04d690b49

Comment 9 Fedora Update System 2016-12-13 20:11:46 UTC
sssd-1.14.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0d27da617

Comment 10 Fedora Update System 2016-12-15 02:28:09 UTC
sssd-1.14.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0d27da617

Comment 11 Fedora Update System 2016-12-15 05:02:58 UTC
sssd-1.14.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b04d690b49

Comment 12 Fedora Update System 2016-12-15 05:06:22 UTC
sssd-1.14.2-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-66bc868b6e

Comment 13 Fedora Update System 2016-12-17 00:23:41 UTC
sssd-1.14.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-12-19 23:22:37 UTC
sssd-1.14.2-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-12-22 18:18:08 UTC
sssd-1.14.2-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.