Bug 139299 - dhcp-3.0.1-11.src.rpm fails to build
dhcp-3.0.1-11.src.rpm fails to build
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dhcp (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
: 140476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 19:37 EST by Johnny Hughes
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: gcc-3.4.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 09:35:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of the build process (6.51 KB, text/plain)
2004-11-14 19:39 EST, Johnny Hughes
no flags Details

  None (edit)
Description Johnny Hughes 2004-11-14 19:37:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
dhcp-3.0.1-11.src.rpm fails to build with the command:

rpmbuild --rebuild dhcp-3.0.1-11.src.rpm on a RHEL 4 - Beta 2
"Everything" install.  It fails to build as both a regular user and as
root.



Version-Release number of selected component (if applicable):
dhcp-3.0.1-11.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.  rpmbuild --rebuild dhcp-3.0.1-11.src.rpm

Additional info:
Comment 1 Johnny Hughes 2004-11-14 19:39:11 EST
Created attachment 106687 [details]
output of the build process

shows the error
Comment 2 Jason Vas Dias 2004-11-15 09:35:00 EST
 Yes, this is a known problem caused by a bug in gcc-3.4.2, 
 which was introduced after the dhcp-3.0.1-11 RPM was built.
 The gcc bug ( PR c/18282 ) is now fixed in gcc-3.4.3-2 .
 You can also build DHCP with the gcc33 (gcc 3.3.4) compiler
 with no errors, by editing the dhcp.spec file as follows:
 --- dhcp.spec line 127:
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's/-mtune\=pentium4//g'`
./configure --copts "$RPM_OPT_FLAGS"
make %{?_smp_mflags} CC="gcc33"
 ---
 
Comment 3 Jason Vas Dias 2004-11-23 09:43:12 EST
*** Bug 140476 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.