Bug 139331 - [PATCH] Handle all possible GValue types
Summary: [PATCH] Handle all possible GValue types
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: passwd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-15 10:05 UTC by Miloslav Trmač
Modified: 2013-07-02 23:03 UTC (History)
2 users (show)

Fixed In Version: 0.69-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 13:14:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use lu_value_strdup () (1.32 KB, patch)
2004-11-15 10:06 UTC, Miloslav Trmač
no flags Details | Diff

Description Miloslav Trmač 2004-11-15 10:05:24 UTC
The libuser API uses GValues without explicitly describing
what GValue types are applicable, and the old G_TYPE_STRING,
G_TYPE_LONG pair is not enough to represent data (UID/GID
in particular) anymore.

This patch uses a new libuser utility function (available since
0.53-1) instead of explicitly handling select GValue types
(and aborting on others).

It also fixes the CHECK_ERROR macro a bit.

Comment 1 Miloslav Trmač 2004-11-15 10:06:48 UTC
Created attachment 106702 [details]
Use lu_value_strdup ()

Comment 2 Jindrich Novy 2004-11-16 08:55:13 UTC
Could you please fix this:

libstuff.a(libuser.o)(.text+0x248): In function `pwdb_unlock_password':
/home/jnovy/CVS_elvis/password.build/libuser.c:154: undefined
reference to `lu_value_strdup'
libstuff.a(libuser.o)(.text+0x459): In function `pwdb_display_status':
/home/jnovy/CVS_elvis/password.build/libuser.c:235: undefined
reference to `lu_value_strdup'
collect2: ld returned 1 exit status

and add fixed patch here?

CHECK_ERROR macro fix is now commited, thanks.

Comment 3 Miloslav Trmač 2004-11-16 09:06:55 UTC
The patch requires libuser >= 0.53-1, as noted above.

Feel free to postpone accepting it if it would require
updating libuser on your "main" machine (it is
quite unlikely the password field is all numerical
anyway), but it should definitely get in before FC4.

Comment 4 Jindrich Novy 2004-11-16 09:25:35 UTC
I should better read bug description.
OK, upgraded to latest libuser and see no problem any more.

Commited, thanks.


Comment 5 Tomas Mraz 2004-12-09 12:23:23 UTC
Please add BuildPrereq for libuser >= 0.53 to spec.


Comment 6 Jindrich Novy 2005-01-28 13:14:55 UTC
passwd-0.69-1 is now built.


Note You need to log in before you can comment on or make changes to this bug.