This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139332 - kernel BUG at kernel/signal.c:1996
kernel BUG at kernel/signal.c:1996
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 05:32 EST by Joe Orton
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 04:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-11-15 05:32:01 EST
kernel-2.6.9-1.667, athlon, UP.

------------[ cut here ]------------
kernel BUG at kernel/signal.c:1996!
invalid operand: 0000 [#1]
Modules linked in: tun radeon parport_pc lp parport autofs4 sunrpc
ipt_state ip_conntrack iptable_filter ip_tables ip6table_filter
ip6_tables md5 ipv6 joydev button battery ac uhci_hcd ehci_hcd
snd_via82xx snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer
snd_page_alloc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd
soundcore tg3 floppy dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod
CPU:    0
EIP:    0060:[<0212d3b6>]    Not tainted VLI
EFLAGS: 00010293   (2.6.9-1.667)
EIP is at get_signal_to_deliver+0x7b6/0x881
eax: 6171bf60   ebx: 28de1000   ecx: 00000000   edx: 00000083
esi: 00000003   edi: 56a2f5ac   ebp: 56d68210   esp: 28de1edc
ds: 007b   es: 007b   ss: 0068
Process sa-learn (pid: 8101, threadinfo=28de1000 task=56d68210)
Stack: 28de1000 56d68714 28de1fc4 28de1f08 28de1f28 28de1fc4 56d68714
28de1000
       28de1000 021063fd 00000000 ffffffff 37f6d480 558411c4 00000000
28de1f74
       00000000 021c72d9 364be6b4 00000003 00000000 00000080 00000000
00000000
Call Trace:
 [<021063fd>] do_signal+0x55/0xd5
 [<021c72d9>] selinux_file_permission+0x127/0x131
 [<0211cf5b>] autoremove_wake_function+0x0/0x2d
 [<02165573>] vfs_read+0xda/0xe2
 [<02165762>] sys_read+0x3c/0x62
 [<021064a4>] do_notify_resume+0x27/0x37
Code: <3>Debug: sleeping function called from invalid context at
include/linux/rwsem.h:43
in_atomic():0[expected: 0], irqs_disabled():1
 [<0211c8b9>] __might_sleep+0x7d/0x88
 [<0215e27e>] rw_vm+0x216/0x482
 [<0212d38b>] get_signal_to_deliver+0x78b/0x881
 [<0212d38b>] get_signal_to_deliver+0x78b/0x881
 [<0215e9d0>] get_user_size+0x30/0x57
 [<0212d38b>] get_signal_to_deliver+0x78b/0x881
 [<0210682b>] show_registers+0x109/0x15e
 [<02106a2f>] die+0x14a/0x241
 [<02106e08>] do_invalid_op+0x0/0xd5
 [<0213475b>] search_exception_tables+0x1f/0x21
 [<02106e08>] do_invalid_op+0x0/0xd5
 [<02106ed4>] do_invalid_op+0xcc/0xd5
 [<0212d3b6>] get_signal_to_deliver+0x7b6/0x881
 [<0211bd18>] complete_all+0x98/0xfc
 [<02173921>] do_coredump+0x2ed/0x2fb
 [<021433d1>] __generic_file_aio_read+0x164/0x17e
 [<0212d3b6>] get_signal_to_deliver+0x7b6/0x881
 [<021063fd>] do_signal+0x55/0xd5
 [<021c72d9>] selinux_file_permission+0x127/0x131
 [<0211cf5b>] autoremove_wake_function+0x0/0x2d
 [<02165573>] vfs_read+0xda/0xe2
 [<02165762>] sys_read+0x3c/0x62
 [<021064a4>] do_notify_resume+0x27/0x37
 Bad EIP value.
Comment 1 Dave Jones 2005-07-15 15:52:48 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.