Bug 139351 - .src.rpm's don't download
.src.rpm's don't download
Status: CLOSED DUPLICATE of bug 141901
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 09:54 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 12:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2004-11-15 09:54:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.3)
Gecko/20041020

Description of problem:
Using the standard /etc/sysconfig/rhn/sources, and marking that I wish
to download .src.rpm's as well, no .src.rpm's appear.

Instead I get files such as this:

[njh@njh up2date]$ cat kdesdk-3.3.1-1.src.rpm
This site is a Mirror for:
        Operating Systems:
        Mandrake Linux  (/pub/linux/mandrake)
                        http://mandrake.secsup.org/
                        rsync -rtlzv --delete
rsync.secsup.org::mandrake <your path>
                        rsync -rtlzv --delete
rsync.secsup.org::mandrake-devel <your path>
                        rsync -rtlzv --delete
rsync.secsup.org::mandrake-iso <your path>
                        rsync -rtlzv --delete
rsync.secsup.org::mandrake-old <your path>

        Debian Linux    (/pub/linux/debian)
                        http://debian.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::debian
<your path>
        Beehive Linux   (/pub/linux/beehive)
                        http://beehive.secsup.org/
                        rsync -rtlzv --delete
rsync.secsup.org::beehive <your path>
        RedHat Linux    (/pub/linux/redhat)
                        http://redhat.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::redhat
<your path>
        OpenBSD         (/pub/openbsd)
                        http://openbsd.secsup.org/
                        rsync -rtlzv --delete
rsync.secsup.org::openbsd <your path>
        SunFreeware     (/pub/solaris/freeware)
                        http://sunfreeware.secsup.org/
                        rsync -rtlzv --delete
rsync.secsup.org::sunfreeware <your path>

        Applications:
        Apache          (/pub/apache)
                        http://apache.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::apache
<your path>

        Other:
        Perl/CPAN       (/pub/perl)
                        http://perl.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::perl
<your path>
        Ximian          (/pub/software/ximian)
                        http://ximian.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::ximian
<your path>
        Mirc            (/pub/software/mirc)
                        http://mirc.secsup.org/
        MySQL           (/pub/software/mysql)
                        http://mysql.secsup.org/
                        rsync -rtlzv --delete rsync.secsup.org::mysql
<your path>

ftp and http connections are not limited for bandwidth or number
of connections. Rsync connections are limited to 10 per category.
If you notice any issues, please email:
        ftp@secsup.org
Thanks


Version-Release number of selected component (if applicable):
up2date-4.3.47-5

How reproducible:
Always

Steps to Reproduce:
1. use standard sources file
2. mark to download .src.rpm as well
3. run up2date -fdu
    

Actual Results:  source rpms full of junk

Expected Results:  Correct source rpms

Additional info:
Comment 1 Nigel Horne 2004-12-08 03:40:36 EST
I just saw this failure:


root@njh fed3]# up2date -fdu
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-3
using mirror: http://ftp.esat.net/pub/linux/fedora/3/i386/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc3
using mirror: http://mirrors.kernel.org/fedora/core/updates/3/i386/

Fetching Obsoletes list for channel: fedora-core-3...

Fetching Obsoletes list for channel: updates-released-fc3...

Name                                    Version        Rel
----------------------------------------------------------
shadow-utils                            4.0.3          56            
   i386


Testing package set / solving RPM inter-dependencies...
########################################
shadow-utils-4.0.3-56.i386. ########################## Done.
shadow-utils-4.0.3-56.src.r  There was a fatal error communicating
with the server. The message was:

An HTTP error occurred:
URL:
http://mirrors.kernel.org/fedora/core/updates/3/i386//SRPMS/shadow-utils-4.0.3-56.src.rpm
Status Code: 404
Error Message: Not Found

[root@njh fed3]#
Comment 2 Steven D. Harris 2005-04-29 14:58:22 EDT
This is a duplicate of bug #141901
Comment 3 Rahul Sundaram 2005-06-27 12:17:31 EDT

*** This bug has been marked as a duplicate of 141901 ***

Note You need to log in before you can comment on or make changes to this bug.