Bug 139380 - libxml2-2.6.16-3 breaks evolution-connector
libxml2-2.6.16-3 breaks evolution-connector
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 12:49 EST by Tom DuVally
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 17:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom DuVally 2004-11-15 12:49:06 EST
Description of problem:
evolution-connector-2.0.2-1 will crash after upgrade libxml2 to
2.6.16-3.  The previos version (2.6.14-2) does not adversely effect
evolution-connector

Version-Release number of selected component (if applicable):
2.6.16-3

How reproducible:
Always

Steps to Reproduce:
1. Setup evolution to connect to exchange
2. Upgrade libxml2, libxml2-python and libxml2-devel to 2.6.16-3
3. start evolution and attempt to connect to exchange account
  
Actual results:
Error pop-up "The Application 'exchange-exchange-storage' has quit
unexpectedly."  Exchange account does not function.

Expected results:
No error on evolution start-up and normal access to exchange account.

Additional info:
Only by downgrading to previous version of libxml2 was
evolution-connector able to work again.
Comment 1 Daniel Veillard 2004-11-15 16:30:44 EST
can you provide a stack trace to get an idea or more information
about how to reproduce this ?

Daniel
Comment 2 Dave Malcolm 2004-11-15 17:27:36 EST
I tried but was unable to reproduce this (using locally-built
libxml2-2.6.16 packages); I can still access my Exchange account.
Comment 3 Dave Malcolm 2004-11-15 17:31:01 EST
Tom DuVally: please can you provide a stack backtrace for the
evolution-exchange-storage process when it crashes.  See this page for
more information on how to do this:
http://fedora.linux.duke.edu/wiki/index.cgi/StackTraces
Comment 4 Tom DuVally 2004-11-17 12:54:17 EST
I can't seem to recreate it myself.  It definitely happened first time
around.  I've now tried it on 2 seperate systems and can't reproduce
it.  I guess you can close this one as a false alarm.

The only thing I can think of is that the first time around I may have
had setting left over from 1.4.x.  I decided NOT to migrate and to
start from scratch.  Maybe there was a problem there.  I'm not
familiar with the gconf stuff.
Comment 5 Daniel Veillard 2004-11-17 12:59:25 EST
okay, strange. As far as I know gconf doesn't use libxml2 as
shipped.
Thanks for providing further informations, since nobody else 
reported problems about it, I'm tempted to close it as an 
unreproducable problem.

  thanks !

Daniel
Comment 6 Dave Malcolm 2004-11-17 13:06:56 EST
Evolution stores XML strings into GConf for much of its configuration,
and uses libxml2 to parse/generate the XML strings from/to its
internal data structures - which is what I believe comment #4 is
referring to.
Comment 7 Daniel Veillard 2004-11-17 13:10:41 EST
I though GConf was using expat by default for parsing the XML 

Daniel
Comment 8 Dave Malcolm 2004-11-17 13:17:35 EST
Yes, the standard GConf backend stores data in files in the user's home 
directory in an XML representation.  I don't know offhand which parser
is used for this.

This is at a different level; when values are returned from GConf into
the app, Evolution interprets some string values as miniature XML
files, and parses them accordingly, using libxml2.
(so if you look at the raw XML backend representation, you see an XML
file containing strings, which in turn are escaped XML files - ugh!)
Comment 9 Dave Malcolm 2004-11-17 13:19:36 EST
I'm reassigning this to evolution-connector, and reopening, since I
suspect there may be a simple bug in the app.

Tom DuVally: was this bug associated with the first time you ran the
Connector after a migration between Evolution versions?
Comment 10 Dave Malcolm 2004-11-17 13:20:13 EST
(reassigning to me)
Comment 11 Matthew Miller 2006-07-10 17:01:22 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 12 John Thacker 2006-10-30 17:48:29 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.