Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1393855 - Please move wireshark to /usr/bin
Please move wireshark to /usr/bin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
: 1380537 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-10 08:16 EST by Andreas Schneider
Modified: 2016-12-15 12:05 EST (History)
8 users (show)

See Also:
Fixed In Version: wireshark-2.2.2-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-01 09:33:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed spec file change (5.21 KB, patch)
2016-11-30 09:21 EST, Martin Sehnoutka
asn: review+
Details | Diff
proposed spec file (41.29 KB, text/plain)
2016-11-30 09:22 EST, Martin Sehnoutka
no flags Details

  None (edit)
Description Andreas Schneider 2016-11-10 08:16:32 EST
Description of problem:

Please move wireshark from /usr/sbin to /usr/bin.

I think Wireshark is mostly used to open and read pcap files. It doesn't require root privileges for this!


Thanks.
Comment 1 Peter Lemenkov 2016-11-10 09:02:14 EST
(In reply to Andreas Schneider from comment #0)
> Description of problem:
> 
> Please move wireshark from /usr/sbin to /usr/bin.
> 
> I think Wireshark is mostly used to open and read pcap files. It doesn't
> require root privileges for this!

It's certainly not :)
For example I'm using it for making dumps more often that tshark or tcpdump. Btw tcpdump cannot select between available network interfaces (while tshark can).

Still even if it requires root provileges, there is no point to store anything in /sbin-directories anymore. It was put there just because, due to following rules from our historical UN*X heritage.

So bottom line - I also believe we should move it to /usr/bin.
Comment 2 Peter Robinson 2016-11-18 09:29:15 EST
*** Bug 1380537 has been marked as a duplicate of this bug. ***
Comment 3 Martin Sehnoutka 2016-11-24 05:10:55 EST
(In reply to Peter Lemenkov from comment #1)
> (In reply to Andreas Schneider from comment #0)
> > Description of problem:
> > 
> > Please move wireshark from /usr/sbin to /usr/bin.
> > 
> > I think Wireshark is mostly used to open and read pcap files. It doesn't
> > require root privileges for this!
> 
> It's certainly not :)

Do you want to move all executables produced by wireshark package into /usr/bin or just wireshark?

$ rpm -ql wireshark-cli  | grep sbin
/usr/sbin/capinfos
/usr/sbin/captype
/usr/sbin/dftest
/usr/sbin/dumpcap
/usr/sbin/editcap
/usr/sbin/mergecap
/usr/sbin/randpkt
/usr/sbin/rawshark
/usr/sbin/reordercap
/usr/sbin/text2pcap
/usr/sbin/tshark
Comment 4 Andreas Schneider 2016-11-25 03:30:49 EST
I would move all of them to /usr/bin
Comment 5 Peter Lemenkov 2016-11-25 06:23:21 EST
(In reply to Martin Sehnoutka from comment #3)
(In reply to Andreas Schneider from comment #4)
> I would move all of them to /usr/bin

Agree.
Comment 6 Martin Sehnoutka 2016-11-30 09:21 EST
Created attachment 1226344 [details]
Proposed spec file change
Comment 7 Martin Sehnoutka 2016-11-30 09:22 EST
Created attachment 1226345 [details]
proposed spec file
Comment 8 Martin Sehnoutka 2016-12-01 05:44:46 EST
I pushed the new spec file into git and made a new build.

version with the change: wireshark-2.2.2-3.fc26
Comment 9 Martin Sehnoutka 2016-12-06 09:59:18 EST
The patch broke updates on Fedora Rawhide, the cause is a call to update-alternatives which expects the path to be `/usr/sbin/wireshark`.

Related rhbz: #1400654

We came up with two possible solutions: Either remove all symlinks under name wireshark and then create a new symlink pointing to /usr/bin/ or create a new group with called for instance `wireshark-gui` which will be preferred over sbin because of the order in $PATH variable.

update-alternatives --install /usr/bin/wireshark wireshark-gui
/usr/bin/wireshark-qt 50

Do you have any comment related to this issue?
Comment 10 nucleo 2016-12-15 12:05:26 EST
# rpm -q wireshark-qt
wireshark-qt-2.2.2-4.fc26.i686

Problem with desktop file from this rpm:

# grep Exec /usr/share/applications/wireshark.desktop
TryExec=/usr/sbin/wireshark
Exec=/usr/sbin/wireshark %

# /usr/sbin/wireshark
-bash: /usr/sbin/wireshark: No such file or directory

Note You need to log in before you can comment on or make changes to this bug.