Bug 139386 - CD test failure at 99%
CD test failure at 99%
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 13:44 EST by Sharas
Modified: 2015-01-04 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharas 2004-11-15 13:44:46 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I wasted 3 cd-rs to burn FC3 CD1 and still the media test fails at 
99%, so as for all other 3 CDs. Crap happens when burning CDs, but 6 
times the same.. All went OK with FC2.
Comment 1 Sitsofe Wheeler 2004-12-03 17:00:58 EST
Does the testing suceed if you start the installer with "linux cddma=off" ? If
so then this a dup of bug 106685
Comment 2 Dan Hollis 2005-02-03 18:00:25 EST
i get exactly the same thing with cddma=off

it stops at 99% and switching consoles it gives sector read errors
that looks like its trying to read off the end of the CD.
Comment 3 D. Hugh Redelmeier 2005-03-14 14:52:46 EST
This might be related to bug 151088.

The workaround is to burn the CD with extra padding.  cdrecord has a
-pad option that should do it (I haven't tried it).  Perhaps 15
sectors is not enough -- you might need to use padsize=33s.

What I has worked for me is appending a a couple of megabytes of zero
to the .iso file before burning it with cdrecord.  I think that the
padsize=33s approach is cleaner.
Comment 4 Dan Hollis 2005-03-14 17:28:43 EST
-pad does not work. have not tried padsize.
Comment 5 Dan Hollis 2005-05-23 16:00:24 EDT
this appears to be because of the readahead in kernel.

someone suggested using raw devices to bypass readahead.
Comment 6 Dave Jones 2005-07-15 13:59:21 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Dave Jones 2005-10-02 20:28:05 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.