Bug 1393947 - Review Request: cinch - A tool for provisioning Jenkins components for CI
Summary: Review Request: cinch - A tool for provisioning Jenkins components for CI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fl@sh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-10 16:55 UTC by greg.hellings
Modified: 2016-12-29 08:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-29 07:19:09 UTC
alex.mail.1534: fedora-review+


Attachments (Terms of Use)

Description greg.hellings 2016-11-10 16:55:54 UTC
Spec URL: https://fedorapeople.org/~greghellings/cinch/cinch.spec
SRPM URL: https://fedorapeople.org/~greghellings/cinch/cinch-0.2.0-1.fc24.src.rpm
Description: Cinch is an Ansible-based tool for configuring Jenkins systems to enhance the Continuous Integration experience.
Fedora Account System Username: greghellings

Comment 2 Fl@sh 2016-12-06 18:24:35 UTC
success build: http://koji.fedoraproject.org/koji/taskinfo?taskID=16774595

Comment 3 Fl@sh 2016-12-07 18:39:21 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package contains BR: python2-devel or python3-devel
- If (and only if) the source package includes the text of the license(s)
  in its own file, then that file, containing the text of the license(s)
  for the package is included in %license.
  Note: License file LICENSE is not marked as %license
  See:
  http://fedoraproject.org/wiki/Packaging/LicensingGuidelines#


===== MUST items =====

Generic:
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[!]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated". 88 files have unknown license. Detailed
     output of licensecheck in /home/Flash/Downloads/review-
     cinch/licensecheck.txt
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[-]: Package contains no bundled libraries without FPC exception.
[-]: Changelog in prescribed format.
[?]: Sources contain only permissible code or content.
     // see for warnings in rpmlint Checking.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[-]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
[x]: Package complies to the Packaging Guidelines
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[-]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: cinch-0.2.1-1.fc26.noarch.rpm
          cinch-0.2.1-1.fc26.src.rpm
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli_user.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli_user.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/__init__.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/__init__.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/bin/entry_point.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/bin/entry_point.py 644 /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli.py 644 /bin/bash 
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/line_match.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/line_match.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/jenkins_security_enabled.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_security_enabled.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/bin/__init__.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/bin/__init__.py 644 /usr/bin/env python
cinch.noarch: W: no-manual-page-for-binary cinch
cinch.src:11: W: mixed-use-of-spaces-and-tabs (spaces: line 11, tab: line 1)
2 packages and 0 specfiles checked; 13 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli.py 644 /bin/bash 
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/bin/entry_point.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/bin/entry_point.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/__init__.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/__init__.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/line_match.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/line_match.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli_user.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_cli_user.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/library/jenkins_security_enabled.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/library/jenkins_security_enabled.py 644 /usr/bin/env python
cinch.noarch: E: wrong-script-interpreter /usr/lib/python2.7/site-packages/cinch/bin/__init__.py /usr/bin/env python
cinch.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/cinch/bin/__init__.py 644 /usr/bin/env python
cinch.noarch: W: no-manual-page-for-binary cinch
1 packages and 0 specfiles checked; 13 errors, 1 warnings.



Requires
--------
cinch (rpmlib, GLIBC filtered):
    /usr/bin/python2
    ansible
    python(abi)
    python-plumbum



Provides
--------
cinch:
    cinch
    python2.7dist(cinch)
    python2dist(cinch)



Source checksums
----------------
http://github.com/RedHatQE/cinch/releases/download/v0.2.1/cinch-0.2.1.tar.gz :
  CHECKSUM(SHA256) this package     : ff1f53dd57695a23b4d75a2b3b3f54936d21add1448ca9f7385d6d6dbb1bd867
  CHECKSUM(SHA256) upstream package : ff1f53dd57695a23b4d75a2b3b3f54936d21add1448ca9f7385d6d6dbb1bd867


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review --prebuilt --name cinch
Buildroot used: fedora-rawhide-x86_64
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

So, need to fix:
    %%license in %%files;
    develop2-devel in BR;
    rpmlint checking errors.

Comment 4 Fl@sh 2016-12-07 20:21:16 UTC
*python2-devel in BR;

Comment 5 greg.hellings 2016-12-13 04:05:38 UTC
New SRPM: https://fedorapeople.org/~greghellings/cinch/cinch-0.2.1-2.fc25.src.rpm

I added the %license line
I switched python-devel to python2-devel instead

I'm guessing that's what you were meaning when you called out python-devel? It does need a Python development package in order to install.

Comment 6 Fl@sh 2016-12-14 11:34:53 UTC
(In reply to greg.hellings from comment #5)
> New SRPM:
> https://fedorapeople.org/~greghellings/cinch/cinch-0.2.1-2.fc25.src.rpm
> 
> I added the %license line
> I switched python-devel to python2-devel instead
> 
> I'm guessing that's what you were meaning when you called out python-devel?
> It does need a Python development package in order to install.

About python-devel: fedora-review report suggests python2-devel for python2 packages, because python2-devel is a another provided name of python-devel.

I think that need to rename package to according with guidelines
https://fedoraproject.org/wiki/Packaging:Naming?rd=Packaging:NamingGuidelines#Python_modules .
If you want develop package on python2 only, then it will be python-cinch as example, else python2-chinch (python3-cinch for python3).

Also, see for common case for Source0:
https://fedoraproject.org/wiki/Packaging:SourceURL?rd=Packaging/SourceURL .
Then this can be in your case:
https://github.com/RedHatQE/%{name}/archive/v%{version}.tar.gz . It is more usable and readable.

Comment 7 greg.hellings 2016-12-14 19:28:37 UTC
Naming the package "python2-cinch" would be incorrect. This is not a Python module, but an end-user application written in mostly Ansible with a few call-ins through Python.

That URL for Source0 you propose is not correct. I can substitute in the %{name} macros if you think that's necessary, but upstream (me) does not directly release through the archive link on GitHub but rather through the release download links that I reference in the spec file.

Comment 8 Fl@sh 2016-12-15 07:57:46 UTC
About naming i understand, ok. About %{name} macros -- need to substitute, it is a guidelines requires.
Last misunderstanding: i get sources tar.gz by my link -- v0.2.1.tar.gz,
your link -- cinch-0.2.1.tar.gz, which are absolutely identical besides their names. What a problem?

Comment 9 greg.hellings 2016-12-16 17:16:02 UTC
New SRPM and spec file: https://fedorapeople.org/~greghellings/cinch/cinch-0.2.1-3.fc25.src.rpm

The problem with using the /archive/ instead of the /releases/download/ link is that upstream is not using the /archive/ link as its official release mechanism. We have opted to go with explicit release files being uploaded instead of just plain tagging.

The new spec/SRPM uses the %{name} macros where appropriate to construct the URL for Source0.

Comment 10 Fl@sh 2016-12-16 19:17:43 UTC
ok, all misunderstanding were eliminated. Although it would be better to use the macro %{name} in %%prep and %%files, but i not want to delay the package. These small discrepancies can be corrected in the next release(s).
Approved.

Comment 11 Fedora Update System 2016-12-20 20:24:39 UTC
cinch-0.2.1-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f997abaa82

Comment 12 Fedora Update System 2016-12-20 20:29:01 UTC
cinch-0.2.1-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d05af72e68

Comment 13 Fedora Update System 2016-12-21 15:49:02 UTC
cinch-0.2.1-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d05af72e68

Comment 14 Fedora Update System 2016-12-21 15:50:56 UTC
cinch-0.2.1-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f997abaa82

Comment 15 Fedora Update System 2016-12-29 07:19:09 UTC
cinch-0.2.1-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-12-29 08:19:54 UTC
cinch-0.2.1-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.