Bug 139435 - [RHEL3-U4][crash] crash doesn't work with maxcpus=1 on SMP kernel
[RHEL3-U4][crash] crash doesn't work with maxcpus=1 on SMP kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: netdump (Show other bugs)
3.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Akira Imamura
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 17:50 EST by Yuuichi Nagahama
Modified: 2007-11-30 17:07 EST (History)
12 users (show)

See Also:
Fixed In Version: RHBA-2005-186
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 08:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuuichi Nagahama 2004-11-15 17:50:28 EST
Description of problem:
Architecure: x86_64
Crash doesn't work with maxcpus=1 on SMP kernel.
The issue in the process of getting the number of CPUs in crash.


Version-Release number of selected component (if applicable):
RHEL3-U4

How reproducible: Everytime


Steps to Reproduce:
1. Execute crash on maxcpus=1 on SMP kernel

  
Actual results: Crash doesn't work


Expected results: Crash works.


Additional info:
Comment 1 Dave Anderson 2004-11-16 09:01:47 EST
I ran into a similar problem with an ia64 netdump dumpfile
as a result of the crash patch from Fujitsu that made NR_CPUS
a per-processor #define -- and subsequently fixed it in my
public crash utility release on people.redhat.com in version
3.8-5.10.  That fix will be reflected in a RHEL3-U5 update
for crash.

I just tested 3.8-5.10 on nocona1.lab, a 2-cpu x86_64, and it
works OK with maxcpus set to 1, so I cannot reproduce it:

[root@nocona1 root]# cat /proc/cmdline
ro root=LABEL=/ hdc=ide-scsi maxcpus=1
[root@nocona1 root]# crash

crash 3.8-5.10
Copyright (C) 2002, 2003, 2004  Red Hat, Inc.
Copyright (C) 2004  IBM Corp.
Copyright (C) 1998-2004  Hewlett-Packard Co
Copyright (C) 1999, 2002  Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002  Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public
License, and you are welcome to change it and/or distribute copies of
it under certain conditions.  Enter "help copying" to see the
conditions. This program has absolutely no warranty.  Enter "help
warranty" for details.

GNU gdb 6.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are welcome to change it and/or distribute copies of it under
certain conditions. Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details. This GDB was configured as "x86_64-unknown-linux-gnu"...

      KERNEL: /boot/vmlinux-2.4.21-21.netdump8.EL
   DEBUGINFO: /usr/lib/debug/boot/vmlinux-2.4.21-21.netdump8.EL.debug
    DUMPFILE: /dev/mem
        CPUS: 1
        DATE: Tue Nov 16 09:56:15 2004
      UPTIME: 00:25:49
LOAD AVERAGE: 0.11, 0.03, 0.01
       TASKS: 41
    NODENAME: nocona1.lab.boston.redhat.com
     RELEASE: 2.4.21-21.netdump8.EL
     VERSION: #1 SMP Tue Oct 26 13:18:44 EDT 2004
     MACHINE: x86_64  (1866 Mhz)
      MEMORY: 4.5 GB
         PID: 2232
     COMMAND: "crash"
        TASK: 10117cb2000
         CPU: 0
       STATE: TASK_RUNNING (ACTIVE)

crash>

Can you copy nocona1.lab:/usr/bin/crash to the x86_64 machine
where you see this problem and test it?  (or get the latest public
version from people.redhat.com/anderson and build it?)

Thanks,
  Dave


Comment 2 Akira Imamura 2004-12-06 14:59:23 EST
I verified on hammer1.lab that crash-3.10-1 does not have this 
problem.

Thanks,
Akira
Comment 3 Dave Anderson 2005-02-18 11:32:16 EST
Fix checked into CVS for RHEL3 and RHEL4.

RHEL3:

* Fri Feb 04 2005 Dave Anderson <anderson@redhat.com> 3.10-4
- Fix for handling ia64 and x86_64 machines booted with maxcpus=1 on
  an SMP kernel.  BZ #139435

RHEL4:

* Thu Feb 10 2005 Dave Anderson <anderson@redhat.com> 3.10-7
- Fix for handling ia64 and x86_64 machines booted with maxcpus=1 on
  an SMP kernel.  BZ #139435

Comment 4 Tim Powers 2005-05-19 08:47:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-184.html

Note You need to log in before you can comment on or make changes to this bug.