Bug 139453 - Can't find isos in root directory with askmethod on USB hard drive.
Can't find isos in root directory with askmethod on USB hard drive.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 20:40 EST by Kim Lux
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2004-11-15 20:40:58 EST
Description of problem: 
 
Can't find ISOs in root directory of a USB hard drive when using 
askmethod. 
 
Version-Release number of selected component (if applicable): 
 
Whatever ships with FC3-final, before any upgrades are applied.  
 
 
How reproducible: 
 
I wasn't able to get it to work properly in 4 tries.  With the work 
around (explained below) it worked the first time.  
 
 
Steps to Reproduce: 
 
1.Load ISOs onto the root directory of the 3rd partition of a USB 
hard drive.  The fs on the partition should be ext3.  (I used a Linux 
hard drive where partion 1 was /boot, partition 2 was swap and 
partition 3 was /.) 
 
2.Boot a PC with the FC3 disk 1 cdrom.  At the prompt, use "linux 
askmethod". 
 
3. When queried for the device, select /dev/sda3 (ie for the USB 
drive, partition #3).  Leave the "iso directory" empty or put "/" in 
it.  
   
Actual results: 
 
Anaconda will report that the ISO files could not be found on the 
drive.  They are present in the root directory.   
 
Expected results: 
 
Anaconda should have found the files and installed with them. 
 
Additional info: 
 
Work around: put the files in a directory.  I used /iso.  Use this 
directory for the "iso directory" when queried, ie "/iso".  When the 
directory is used, Anaconda installs Linux without any trouble.
Comment 1 Jeremy Katz 2004-11-16 11:50:15 EST
What messages do you see on tty3 when this occurs?
Comment 2 Kim Lux 2004-11-16 12:00:21 EST
Sorry, I forgot to look.  I always forget that ttys are available for
viewing messages.  Someone should put a reminder in anaconda about
that so that people like me do look.

I might be building another server in the near future.  I'll check it
out then.
Comment 3 Kim Lux 2004-11-20 11:18:21 EST
I did an install from a hard drive yesterday and anaconda was able to 
find the ISOs in the root directory without any trouble.   
 
The hard drive used for the install was an IDE mounted directly on 
the computer, not a USB as it was the first time.   
 
I'll probably be doing some installs from a USB drive in the near 
future and I'll report back then.  I wanted to do a USB install on 
the machine yesterday, if only to test, but it was an old machine and 
the USB controller wasn't recognized.  
Comment 4 Jeremy Katz 2005-09-21 15:04:00 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.

Note You need to log in before you can comment on or make changes to this bug.