Bug 1394611 - the latest mediawriter asks for password twice when write the server media to usb disk
Summary: the latest mediawriter asks for password twice when write the server media to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1412057 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-14 03:17 UTC by lnie
Modified: 2017-05-27 03:01 UTC (History)
2 users (show)

Fixed In Version: mediawriter-4.1.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-27 03:01:21 UTC
Type: Bug


Attachments (Terms of Use)
journal (76.42 KB, text/x-vhdl)
2016-11-14 03:17 UTC, lnie
no flags Details
picture 1 (452.41 KB, image/jpeg)
2016-11-14 03:19 UTC, lnie
no flags Details
picture 2 (549.11 KB, image/jpeg)
2016-11-14 03:20 UTC, lnie
no flags Details
blinking window (737.60 KB, application/octet-stream)
2016-11-14 03:27 UTC, lnie
no flags Details

Description lnie 2016-11-14 03:17:43 UTC
Created attachment 1220239 [details]
journal

Description of problem:
After "finish writing",mediawriter asks for password to “check the written data“,and if you don't type the password in time,you will see picture 2.
Even if you are lucky:watch the screen and see the pop up and type in the password,there is still something else: the screen keeps blinking from time to time.

Version-Release number of selected component (if applicable):
mediawriter-4.0.4-0.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2016-11-14 03:19:28 UTC
Created attachment 1220240 [details]
picture 1

Comment 2 lnie 2016-11-14 03:20:17 UTC
Created attachment 1220241 [details]
picture 2

Comment 3 lnie 2016-11-14 03:27:24 UTC
Created attachment 1220242 [details]
blinking window

Comment 4 Martin Bříza 2016-11-16 10:38:06 UTC
Thank you for the report. The blinking screen is a different issue than the second password prompt. I know about the problem, unfortunately, however, I didn't find enough time to fix it because it requires some structural changes to how FMW works in Linux. Now we don't use polkit directly at all - everything is handled through udisks2/storaged. However, there's a timeout for how long you get the authorization for calling privileged methods on the UDisks2 interfaces and sometimes we hit it between the writing and checking.

Comment 5 Martin Bříza 2017-01-13 09:22:18 UTC
*** Bug 1412057 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2017-05-18 14:48:58 UTC
mediawriter-4.1.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-dade9f0f49

Comment 7 Fedora Update System 2017-05-20 01:05:50 UTC
mediawriter-4.1.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-dade9f0f49

Comment 8 Fedora Update System 2017-05-27 03:01:21 UTC
mediawriter-4.1.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.