Bug 139481 - netstat -ain giving "Device not found" error
netstat -ain giving "Device not found" error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 04:06 EST by Mark Waterhouse
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 07:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Waterhouse 2004-11-16 04:06:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The option "-n" has a strange effect upon the netstat command.
This has been confirmed in FC1 and RHEL ES 3 (Taroon)



On previous releases, the expected output of "netstat -ain" is;
[root@rh72 mail]# netstat -ain
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP
TX-OVR Flg
eth0   1500   0  764039      0      0      0  485379      0      0   
  0 BNRU
lo    16436   0   13786      0      0      0   13786      0      0   
  0 LRU

However, this now appears to be broken.
[root@rhel3 root]# netstat -ain
Kernel Interface table
Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR
TX-DRP TX-OVR Flg
n: error fetching interface information: Device not found


Version-Release number of selected component (if applicable):
net-tools-1.60-20.1

How reproducible:
Always

Steps to Reproduce:
1. netstat -ain
2.
3.
    

Actual Results:  [root@rhel3 root]# netstat -ain
Kernel Interface table
Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR
TX-DRP TX-OVR Flg
n: error fetching interface information: Device not found

Expected Results:  [root@rhel3 root]# netstat -ain
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP
TX-OVR Flg
eth0   1500   0  764039      0      0      0  485379      0      0   
  0 BNRU
lo    16436   0   13786      0      0      0   13786      0      0   
  0 LRU

Additional info:
Comment 1 Radek Vokal 2004-11-16 07:25:33 EST
The problem is that -i option is expecting interface which follows
right after it, eg. "n" stands for interface and not as option
parameter. You'll get your expected results using netstat -a -i -n. 

Note You need to log in before you can comment on or make changes to this bug.