Bug 139501 - Cannot run Perl modules which uses SNMP.so
Cannot run Perl modules which uses SNMP.so
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 08:18 EST by Mindaugas Riauba
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 08:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mindaugas Riauba 2004-11-16 08:18:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
  "make test" fails while trying to compile any Perl module which tries to use 
SNMP.so.

Version-Release number of selected component (if applicable):
net-snmp-perl-5.0.9-2.30E.6

How reproducible:
Always

Steps to Reproduce:
1. download and extract SNMP::Multi Perl module
2. perl Makefile.PL
3. make
4. make test
    

Actual Results:  # make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
1..1
Can't load '/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-
multi/auto/SNMP/SNMP.so' for module 
SNMP: /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-
multi/auto/SNMP/SNMP.so: undefined symbol: PerlIO_fprintf 
at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.
 at blib/lib/SNMP/Multi.pm line 673
Compilation failed in require at blib/lib/SNMP/Multi.pm line 673.
BEGIN failed--compilation aborted at blib/lib/SNMP/Multi.pm line 673.
Compilation failed in require at test.pl line 13.
BEGIN failed--compilation aborted at test.pl line 13.
not ok 1
make: *** [test_dynamic] Error 255

Expected Results:  Successful test

Additional info:

Searching for "PerlIO_fprintf" in Google gives hints that there was some kind 
of bug in net-snmp
Comment 1 Radek Vokal 2004-11-18 10:45:41 EST
The fix will come out with next update.
Comment 2 Mindaugas Riauba 2004-11-19 00:19:29 EST
  When it will be available? Because now it is quite a showstopper for us.

  And maybe I can download net-snmp-perl-5.0.9-2.30E.12 from beta 
channel? Is this problem fixed here?
Comment 3 Radek Vokal 2004-11-22 02:27:08 EST
It has to pass through our QA team and it's scheduled for RHEL3-U5.
The version fixing your problem is net-snmp-perl-5.0.6-2.30E.13. 
Comment 4 Mindaugas Riauba 2004-11-23 09:37:37 EST
When at least beta version of fixed rpm will be available?
Try to understand me - this bug is critical for us. And I'd like to avoid 
installing all the net-snmp from source.
Comment 5 Radek Vokal 2004-11-23 10:42:07 EST
I've put the "beta" version on my personal page so you'll find it here
- http://people.redhat.com/rvokal/net-snmp/ - there's a source package
and also binaries for i386 (if you need bin rpms for another
architecture let me know) 
Comment 6 Mindaugas Riauba 2004-11-23 11:09:36 EST
Thanks but while trying to update or install I'm getting the following error 
messages. Also librpm* is only -4.2.so in my system.

# rpm -Uvh net-snmp-5.0.9-2.30E.13.i386.rpm net-snmp-utils-5.0.9-
2.30E.13.i386.rpm net-snmp-devel-5.0.9-2.30E.13.i386.rpm net-snmp-perl-
5.0.9-2.30E.13.i386.rpm 
error: Failed dependencies:
        libnetsnmp.so.5 is needed by net-snmp-5.0.9-2.30E.13
        libnetsnmpagent.so.5 is needed by net-snmp-5.0.9-2.30E.13
        libnetsnmphelpers.so.5 is needed by net-snmp-5.0.9-2.30E.13
        libnetsnmpmibs.so.5 is needed by net-snmp-5.0.9-2.30E.13
        librpm-4.3.so is needed by net-snmp-5.0.9-2.30E.13
        librpmdb-4.3.so is needed by net-snmp-5.0.9-2.30E.13
        librpmio-4.3.so is needed by net-snmp-5.0.9-2.30E.13
        libselinux.so.1 is needed by net-snmp-5.0.9-2.30E.13
        net-snmp-libs >= 5.0.9 is needed by net-snmp-5.0.9-2.30E.13
        libnetsnmp.so.5 is needed by net-snmp-utils-5.0.9-2.30E.13
        libnetsnmp.so.5 is needed by net-snmp-perl-5.0.9-2.30E.13
        libnetsnmpagent.so.5 is needed by net-snmp-perl-5.0.9-2.30E.13
        libnetsnmphelpers.so.5 is needed by net-snmp-perl-5.0.9-2.30E.13
        libnetsnmpmibs.so.5 is needed by net-snmp-perl-5.0.9-2.30E.13
        librpm-4.3.so is needed by net-snmp-perl-5.0.9-2.30E.13
        librpmio-4.3.so is needed by net-snmp-perl-5.0.9-2.30E.13
    Suggested resolutions:
        net-snmp-5.0.9-2.30E.6.i386.rpm
Comment 7 Radek Vokal 2004-11-24 04:38:31 EST
Shame on me, I did the built on FC3. Now it should be fine ... You
also need to install net-snmp-libs. 
Comment 8 Mindaugas Riauba 2004-11-24 09:53:31 EST
Everything looks fine now. Modules run. Thank you for the help and rpms.
Comment 9 Dennis Gregorovic 2005-05-19 08:41:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-452.html

Note You need to log in before you can comment on or make changes to this bug.