Bug 139509 - powernow-k8 does not load / work
powernow-k8 does not load / work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 09:41 EST by jon
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 18:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output when debug-acpi is enabled in kernelconfig (15.10 KB, text/plain)
2004-11-16 10:51 EST, jon
no flags Details

  None (edit)
Description jon 2004-11-16 09:41:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
After a fresh install of FC3 i see the following message in my syslog:

powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09b)
powernow-k8: BIOS error: numpst must be 1

Because of that cool and quiet (cpufreq / powernow) does not work. Searching the web brought up the following :
http://www.redhat.com/archives/fedora-test-list/2004-May/msg01499.html
It seems that the acpi-fallback option does not work.

However i already run the latest available kernel of fedora-core.
My Motherboard is an MSI 6702 (aka K8T Neo-FIS2R) with the latest bios (v1.8). Cool and quiet support is enabled in bios.

If you need more infos feel free to contact me.

Greetings Jan

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Boot stock fedora core 3 kernel on the above Mobo
2. Try to enable cpuspeed
3. watch the above message
    

Actual Results:  My dmesg-output :
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09b)
powernow-k8: BIOS error: numpst must be 1

Expected Results:  I expespected powernow to work ;-). Actually when i used linux-2.6.9-rc3-mm3 on an debian (testing) system powernow worked for me.

Additional info:
Comment 1 jon 2004-11-16 10:51:06 EST
Created attachment 106808 [details]
dmesg output when debug-acpi is enabled in kernelconfig

Hi
i recompiled my kernel with CONFIG_ACPI_DEBUG=y and attached the full dmesg
output. Unfortunately the powernow-k8 driver stays quiet and does not say why
he is not using acpi.
Greetings Jan
Comment 2 jon 2004-11-16 18:32:24 EST
I tried kernel 2.6.10-rc2-mm1 but it would not boot under fedora. So 
i fired up Debian (testing/i386) and tried the kernel there. Powernow 
is working : 
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 
1.00.09e) 
powernow-k8:    0 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV) 
powernow-k8:    1 : fid 0xa (1800 MHz), vid 0x6 (1400 mV) 
powernow-k8:    2 : fid 0xc (2000 MHz), vid 0x2 (1500 mV) 
 
So could you please update the powernow driver in Fedora Cores 
kernel, so that me and others could use this feature. 
 
Thank Jan 
Comment 3 Mark Adams 2004-11-22 04:37:47 EST
I'd like to confirm the bug; I also have an MSI K8T Neo with latest
bios (1.8), and see the same error on bootup. I'm also running FC3 x86_64.
Comment 4 jon 2004-11-22 07:08:15 EST
linux Kernel 2.6.10-rc2 runs fine under fedora core 3 und has the 
problem fixed (at least for me), so you may want to try this kernel 
out. 
Greetings Jan 
Comment 5 David Highley 2005-06-23 22:55:29 EDT
It seems that the issue has reappeared in Fedora core 4 Kernel 2.6.11-1.1369.

NET: Registered protocol family 1
NET: Registered protocol family 17
powernow-k8: Found 2 AMD Athlon 64 / Opteron processors (version 1.40.2)
powernow-k8: MP systems not supported by PSB BIOS structure
powernow-k8: MP systems not supported by PSB BIOS structure
ACPI wakeup devices:
PCI1 USB0 USB1 UAR1 GOLA GLAN GOLB SMBC AC97 MODM PWRB
ACPI: (supports S0 S1 S4 S5)
Comment 6 Dave Jones 2005-07-15 14:42:59 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Sven-Erik Petermann 2006-01-09 04:32:25 EST
Fedora Core 4 and kernel-2.6.14-1.1656_FC4 still has this problem.
dmesg is showing
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.50.4)
powernow-k8: BIOS error: numpst must be 1
The system is running on a Mobile AMD Sempron 3000+.
Also, running service cpuspeed restart gives:
FATAL: Error inserting powernow_k8
(/lib/modules/2.6.14-1.1656_FC4/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k8.ko):
No such device
The file powernow-k8.ko is there, though.

Note You need to log in before you can comment on or make changes to this bug.