Bug 139514 - NETDEV WATCHDOG: eth0: transmit timed out
NETDEV WATCHDOG: eth0: transmit timed out
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 10:07 EST by Gianluca Busco
Modified: 2015-01-04 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 04:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Busco 2004-11-16 10:07:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I am seeing the following error after my machine has been up for a
while. My eth0 is connected to a switched, local subnet. There is not
a lot of traffic on the interface. Here is the relevant section from
my kernel log:

Nov 17 08:02:21 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:04:57 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:05:27 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:06:45 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:09:36 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:10:06 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 08:10:41 share kernel: NETDEV WATCHDOG: eth0: transmit timed out
Nov 17 08:10:41 share kernel: eth0: Transmit timed out: status 0050 
0cf0 at 240/300 command 200c0000.
Nov 17 10:49:45 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 10:49:46 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 10:50:16 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 10:54:56 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 10:55:04 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 11:00:05 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 11:00:37 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 11:01:07 share kernel: eth0: wait_for_cmd_done timeout!
Nov 17 11:04:17 share kernel: NETDEV WATCHDOG: eth0: transmit timed out
Nov 17 11:04:17 share kernel: eth0: Transmit timed out: status 0050 
0cf0 at 1483/1543 command 000c0000.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Start the machine
2. Browse some web site
3. 
    

Actual Results:  I can't use network connection.

Additional info:
Comment 1 Steve Bergman 2004-12-28 10:23:46 EST
I just upgraded a machine from RH9 to FC3.  I am running a fully
updated system with kernel 2.6.9-681_FC3 i686 UP.  Last night, it
acted similarly, giving the "NETDEV WATCHDOG: eth1: transmit timed
out" error over and over.  Network access was exceedingly slow.

The pertinent info from lspci"

00:09.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)

00:0d.0 Ethernet controller: Linksys NC100 Network Everywhere Fast
Ethernet 10/100 (rev 11)

Not sure which of the two cards is the offending eth1.  This is the
order in which lspci lists them.

This has happened once.  We are waiting to see if it repeats.  Note
that this machine is running the latest nvidia driver from nvidia.  If
the problem occurs again, I will temporarily revert to the xorg driver.

Gianluca, could you provide some more information about your hardware
configuration?

Comment 2 Need Real Name 2005-01-13 09:39:17 EST
Hi,

I also see this problem, running FC2 on a Dell 4600.
Network interface is:
eth1: Tigon3 [partno(BCM95700A6) rev 7104 PHY(5401)]
(PCI:66MHz:64-bit) 10/100/1000BaseT Ethernet 00:0b:db:ac:ff
:1a
eth1: RXcsums[1] LinkChgREG[1] MIirq[1] ASF[0] Split[0] WireSpeed[0]
TSOcap[0] 

Here are the error messages:
NETDEV WATCHDOG: eth1: transmit timed out
tg3: eth1: transmit timed out, resetting
tg3: tg3_stop_block timed out, ofs=1800 enable_bit=2
tg3: tg3_stop_block timed out, ofs=4800 enable_bit=2
tg3: eth1: Link is down.
tg3: eth1: Link is up at 100 Mbps, full duplex.
tg3: eth1: Flow control is on for TX and on for RX.

It happens a couple of times a day.
Comment 3 David Golden 2005-01-18 14:40:39 EST
I'll add my name to the list of people experiencing something like this.  For
me, I first noticed it around the time of the 2.6.10 upgrade.  After the system
has been up continuously for a while, I get the following messages repeated in
the log:

Jan 10 10:14:23 janus kernel: 0000:03:05.0: tulip_stop_rxtx() failed

Jan 10 10:14:23 janus kernel: NETDEV WATCHDOG: eth1: transmit timed out

In rebooting to fix it, the machine occasionally hangs on iptables shutdown.

Here's my kernel version:
2.6.10-1.741_FC3

Here's my lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:09.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge (non-transparent
mode) (rev 11)
00:0a.0 Unknown mass storage controller: Promise Technology, Inc. PDC20262
(FastTrak66/Ultra66) (rev 01)
00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
00:0c.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
00:0d.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)
02:08.0 USB Controller: NEC Corporation USB (rev 41)
02:08.1 USB Controller: NEC Corporation USB (rev 41)
02:08.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
02:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
03:04.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
03:05.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
03:06.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
03:07.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
Comment 4 David Golden 2005-01-18 14:54:36 EST
Some googling suggests that the problems may be related to this patch:
http://oss.sgi.com/archives/netdev/2004-11/msg00795.html

From the timing of when that went into the FC3 kernel, that would be consistent
with my problems appearning after the last 2.6.9 release or the first couple
2.6.10 releases.  (Because of the delayed appearance, it's hard to tell exactly
which one caused it.)
Comment 5 Dave Jones 2005-07-15 16:16:06 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.