Bug 139532 - Lenience when unlocking screen
Lenience when unlocking screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
: 150760 174311 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 11:26 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-11-16 11:26:25 EST
Description of problem:
Often when I am talking to someone at my desk, my screensaver kicks in.
Not wanting the screensaver to kick in, I immediately move my mouse to turn it off.
This doesn't work under Linux, and it would be nice if it did.
A couple of seconds grace would be good (Windows does do this).

I realise that this feature is debatable, since a password protected screensaver
coming on implies that the computer is locked.

The solution to the problem would be to enhance xscreensaver's "fade to black
when blanking" option.
During the "fade to black", any movement would cancel the screensaver.
Comment 1 Jamie Zawinski 2005-03-21 03:20:20 EST
You can accomplish this by setting "Lock Screen After" to 1.  So the screen
would go black after (say) 5 minutes, and then lock at minute 6.  Between
minutes 5 and 6, mouse motion will unblank without asking for a password.

You can get smaller resolution than 60 seconds by editing .xscreensaver by hand
(but the GUI rounds off to minutes.)
Comment 2 Need Real Name 2005-03-21 15:34:46 EST
Thanks for the tip, but it does something different to what I was hoping for.

I'm paranoid, and like my screensaver coming on to mean that the screen is
locked. Your suggestion would mean that this was not the case :/

I was hoping that there could be a short time during the fade that would let me
cancel the screensaver starting.
Comment 3 Need Real Name 2005-03-22 06:13:52 EST
*** Bug 150760 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2006-01-20 16:02:12 EST
You did it! :)
Comment 5 Need Real Name 2006-01-20 16:10:49 EST
*** Bug 174311 has been marked as a duplicate of this bug. ***
Comment 6 Rahul Sundaram 2006-02-20 05:57:08 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 7 Need Real Name 2006-02-20 11:51:52 EST
"I was hoping that there could be a short time during the fade that would let me
cancel the screensaver starting."

(In reply to comment #4)
> You did it! :)

It's broken again now.
Comment 8 Need Real Name 2006-03-07 04:42:43 EST
It's still broken (it was fixed recently too, oh well).
Comment 9 Red Hat Bugzilla 2007-02-05 14:10:18 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 10 Ray Strode [halfline] 2007-08-14 11:24:04 EDT
Hi guys, this should be fixed again.  Please reopen if you still see the problem
with the latest gnome-screensaver packages.

Note You need to log in before you can comment on or make changes to this bug.