Bug 139533 - LTC12537-NETWORK test of rhr2 failed on REHL4 Beta2
LTC12537-NETWORK test of rhr2 failed on REHL4 Beta2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2 (Show other bugs)
2
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 11:28 EST by IBM Bug Proxy
Modified: 2007-04-18 13:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 11:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error.log (2.27 KB, text/plain)
2004-11-16 11:28 EST, IBM Bug Proxy
no flags Details
"output.log" (42.88 KB, text/plain)
2005-01-20 08:07 EST, IBM Bug Proxy
no flags Details
"output.log" (2.96 KB, text/plain)
2005-01-31 07:46 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2004-11-16 11:28:13 EST
The following has be reported by IBM LTC:  
NETWORK test of rhr2  failed on REHL4 Beta2


Hardware Environment:
 Hostname: plinuxt19b.cn.ibm.com
 HMC     : plinuxt1.cn.ibm.com
 Model   : p655 lpar
 ethernet: pcnet32

Firmware Environment:
 RMRG041029
Software Environment:
 RHEL4 Beta2 isos.
 kernel : 2.6.9-1.648_EL
 rhr2 packages: rhr2-rhel4-0.9-14.9b.noarch.rpm


Steps to Reproduce:
1. Install rhr2-rhel4-0.9-14.9b.noarch.rpm
2. setup rhr2 test env
3. do network test using redhat-ready.

Actual Results:
Test failed. this caused by inet6 addr.

Expected Results:
Test pass.
Additional Information:
 content of file /usr/share/rhr/test/NETWORK
 63    local ipaddr="`ifconfig $interface | \
 64                   awk ' /inet/ { sub("addr:",""); print $2; } '`"
 fyi.
 (adding a blank key after word "inet" will fix this problem)
 64                   awk ' /inet / { sub("addr:",""); print $2; } '`"
 
Following is for your reference.
[root@plinuxt19b rhr]# ifconfig eth1 | awk ' /inet/ { sub("addr:","");
print 
$2; } '
172.30.1.195
fe80::209:6bff:fe4e:2631/64
[root@plinuxt19b rhr]# ifconfig eth1 | awk ' /inet / {
sub("addr:",""); print 
$2; } '
172.30.1.195

Created an attachment (id=7446)
errer log
Comment 1 IBM Bug Proxy 2004-11-16 11:28:47 EST
Created attachment 106811 [details]
error.log
Comment 2 David Lawrence 2004-11-22 12:29:01 EST
Changing product and version.
Comment 3 IBM Bug Proxy 2004-12-27 04:01:18 EST
----- Additional Comments From bujunhui@cn.ibm.com  2004-12-27 03:57 EDT -------
Not fixed in 0.9-14.9i. 

Workaround:
[root@romelp1 tests]# diff NETWORK NETWORK.org -ud
--- NETWORK     2004-12-27 06:09:18.000000000 -0500
+++ NETWORK.org 2004-12-27 08:55:40.491245384 -0500
@@ -68,7 +68,7 @@
   if rhr_ifup $interface; then
    create_testfile $speed
    local ipaddr="`ifconfig $interface | 
-                  awk ' /inet / { sub("addr:",""); print $2; } '`" 
+                  awk ' /inet/ { sub("addr:",""); print $2; } '`" 
    udp_test
    tcp_test
    icmp_test 
Comment 4 Gao, Ming 2005-01-10 21:34:24 EST
This problem still exists in rhr2-rhel4-0.9-14.9i.noarch.rpm. To skip 
the ipv6 address, I recommend we change /usr/share/rhr/tests/NETWORK, 
line 71, from

awk ' /inet/ { sub("addr:",""); print $2; } '`"

to

awk ' /inet\>/ { sub("addr:",""); print $2; } '`"
Comment 5 Rob Landry 2005-01-11 08:50:27 EST
Fixed in CVS (rhr2-rhel4-1.0-5)
Comment 6 IBM Bug Proxy 2005-01-20 07:51:55 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-20 07:46 EST -------
NETWORK test still failed in rhr2-rhel4-1.0-10.noarch.rpm on RHEL4-rc kernel on 
Power5 machine. 

In the meantime I typed 12-time password of $server. Obviously it failed to 
install-key.

Here is output while NETWORK running for your information.
===============================================================================
Cleaning scratch space (/tmp/rhr).
Checking/configuring environment...
 NETWORK... nfsd: last server has exited
nfsd: unexporting all filesystems
ip_tables: (C) 2000-2002 Netfilter core team
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 

Prep stage completed.
Press return to continue or control-c to quit

Starting Hardware Info Gathering...
 NETWORK... 
Hardware Info stage completed.
Press return to continue or control-c to quit

Starting interactive mode...
Interactive stage completed.
Starting automated test(s)...
 NETWORK... ip_tables: (C) 2000-2002 Netfilter core team
root@9.3.117.249's password: 
root@9.3.117.249's password: 
audit(1106240733.119:0): avc:  denied  { write } for  pid=18323 
exe=/usr/sbin/httpd name=mibs dev=dm-16 ino=883041 
scontext=root:system_r:httpd_t tcontext=system_u:object_r:usr_t tclass=dir
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 
root@9.3.117.249's password: 
ip_tables: (C) 2000-2002 Netfilter core team

Automated stage completed.
Press return to continue or control-c to quit

Starting review process...
 NETWORK... (checking results)                             [FAILED]
Check stage completed.
Press return to continue or control-c to quit
===========================================================================
Tomorrow I am willing to do NETWORK on power4 machines. and I will post result 
here. 
Comment 7 IBM Bug Proxy 2005-01-20 08:07:06 EST
Created attachment 110005 [details]
"output.log"
Comment 8 IBM Bug Proxy 2005-01-20 08:07:28 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-20 07:56 EST -------
 
Output.log of NETWORK component

I think maybe this failure caused by the lastest calling rhr_ifup() which
locate at /usr/share/rhr/tests/network/functions.

[root@romelp1 0]# tail -10 output.log 
+ local ifname=eth1
+ local slept=0
+ local delay=15
+ ifup eth1
+ ifconfig eth1
+ grep RUNNING -q
+ '[' 0 -gt 15 ']'
+ sleep 1
+ let slept++
133901327173561099663134232016672069426

and what expect result is just like following

+ local ifname=eth1
+ local slept=0
+ local delay=15
+ ifup eth1
+ ifconfig eth1
+ grep RUNNING -q
+ '[' 0 -gt 15 ']
+ slept=0
+ delay=15
+ echo -n 'eth1: waiting for connection...'
eth1: waiting for connection...+ ping -Ac1 172.30.1.180
+ '[' 0 -gt 15 ']'
+ return 0
133901327173561099663134232016672069426


If it return 0, then the network component will be passed. 
Comment 9 IBM Bug Proxy 2005-01-20 08:09:41 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-20 08:00 EST -------
In my previous post, 172.30.1.180 is $Server. so in this case, it should be 
9.3.117.249. 
Comment 10 Rob Landry 2005-01-20 11:16:24 EST

*** This bug has been marked as a duplicate of 145468 ***
Comment 11 IBM Bug Proxy 2005-01-24 00:11:07 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-24 00:05 EST -------
Just Fyi,
To install-key, we can do following as workaround.
Just Fyi,

To install-key, we can do following as workaround.

1) on $server, do 
cat /etc/sysconfig/redhatready2_id_dsa.pub >> /root/.ssh/authorized_keys 
or
2) on $client, do
scp cat /etc/sysconfig/redhatready2_id_dsa.pub >> 
$server/root/.ssh/authorized_keys 
Comment 13 James Laska 2005-01-25 15:11:20 EST
A patch has been submitted to CVS by rlandry to address this issue on 1/18
Comment 14 IBM Bug Proxy 2005-01-25 20:45:32 EST
---- Additional Comments From zhouwu@cn.ibm.com  2005-01-25 20:42 EST -------
Hi RedHat, When could we get this updated rhr package. We are looking forward 
to try it. thanks. 
Comment 15 IBM Bug Proxy 2005-01-27 13:26:48 EST
---- Additional Comments From marksmit@us.ibm.com  2005-01-27 13:21 EST -------
CSDL, here is a link to a new beta RHR that should contain this fix.  Please 
test and update the bug with results.    We will then need to wait until we 
get an official RHR release before we can re-run the certification tests.
http://people.redhat.com/rlandry/rhr2/test/1.0-13/ 
Comment 16 IBM Bug Proxy 2005-01-28 04:35:45 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-28 04:31 EST -------
I have verified NETWORK component of new beta RHR on romelp1.upt.austin.ibm.com 
and it passed. When reliability Test finished next week, I'd like to do more 
network testing on different model machines to check the new beta RHR. Thanks. 
Comment 17 IBM Bug Proxy 2005-01-31 07:46:30 EST
Created attachment 110426 [details]
"output.log"
Comment 18 IBM Bug Proxy 2005-01-31 07:46:40 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-01-31 07:45 EST -------
 
Output.log of NETWORK on cupidlp2

On cupidlp2, NETWORK failed in rhr2-rhel4-1.0-13.noarch.rpm.

HostName: cupidlp2.upt.austin.ibm.com
Model: L4
HMC : sqh7lte.upt.austin.ibm.com 

[root@cupidlp2 5]# ethtool -i eth0
driver: e1000
version: 5.3.19-k2-NAPI
firmware-version: N/A
bus-info: 0000:d0:01.0
[root@cupidlp2 5]# uname -r
2.6.9-5.EL
[root@cupidlp2 5]# pwd
/var/log/rhr/tests/NETWORK/5
[root@cupidlp2 5]# rpm -qa |grep rhr
rhr2-rhel4-1.0-13
[root@cupidlp2 5]# tail -2 /etc/rhr/tests.conf 
#
SERVER="9.3.117.165" 
Comment 19 James Laska 2005-02-01 13:29:59 EST
The most recent failure appears to be a recreate of bug#143739 (LTC13220).
Comment 20 IBM Bug Proxy 2005-02-01 13:41:34 EST
---- Additional Comments From marksmit@us.ibm.com  2005-02-01 13:36 EST -------
CSDL, in today's conf call, RH viewed the latest error appended 
https://bugzilla.linux.ibm.com/show_bug.cgi?id=12537#c21
and verified that is a recreate of 13220.

Also, the latest errata for RHR
http://rhn.redhat.com/errata/RHBA-2005-051.html
fixes another RH partner (not IBM) bug 145468.
RH confirmed that they believe this LTC 12537 is a dup of 145468, so this bug 
should be fixed in the latest errata release of RHR.

Please retest on the RHR errata and close this bug when it passes.  Reopen if 
it does not fix it.
Thank you. 
Comment 21 IBM Bug Proxy 2005-02-04 20:27:03 EST
---- Additional Comments From bujunhui@cn.ibm.com  2005-02-04 20:22 EST -------
(In reply to comment #21)
On cupidlp2, after changing a test server, NETWORK passed in rhr2-rhel4-1.0-
13.noarch.rpm.

I compared the NETWORK in RHR -13 and -14a, and no any update between them, so 
I am willing to close this bug.

Btw, we found rhr2-rhel4-1.0-14a.noarch.rpm in Red Hat's website: 
http://people.redhat.com/rlandry/rhr2/test/1.0-14a/ , which is the same name 
with the latest errata for RHR in http://rhn.redhat.com/errata/RHBA-2005-
051.html, but the md5sum's do not match. 

Note You need to log in before you can comment on or make changes to this bug.