Bug 139542 - egroupware triggers PHP crashes at request shutdown
egroupware triggers PHP crashes at request shutdown
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 11:56 EST by Joe Orton
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-11-16 11:56:45 EST
Description of problem:
Tracker bug for segfaults in PHP triggered by egroupware.org.

Version-Release number of selected component (if applicable):
php-4.3.2-14.ent

Two backtraces which look from php_request_shutdown have been
obtained, which both look like memory corruption:

#0  0x0081e4cf in malloc_consolidate () from /lib/tls/libc.so.6
#1  0x0081e378 in _int_free () from /lib/tls/libc.so.6
#2  0x0081cff8 in free () from /lib/tls/libc.so.6
#3  0x011102af in shutdown_memory_manager (silent=1, clean_cache=0)
    at /usr/src/debug/php-4.3.2/Zend/zend_alloc.c:492
#4  0x010f2e94 in php_request_shutdown (dummy=0x0) at
/usr/src/debug/php-4.3.2/main/main.c:992
#5  0x01132993 in php_apache_request_dtor (f=0x8990dd0)
    at /usr/src/debug/php-4.3.2/sapi/apache2filter/sapi_apache2.c:428
#6  0x01132bf8 in php_output_filter (f=0x8990dd0, bb=0x8b33128)
    at /usr/src/debug/php-4.3.2/sapi/apache2filter/sapi_apache2.c:535
#7  0x0807483c in ap_pass_brigade (next=0x8e1800, bb=0x9c2be10)
    at /usr/src/debug/httpd-2.0.46/server/util_filter.c:550
#8  0x0807c489 in default_handler (r=0x8a80508) at
/usr/src/debug/httpd-2.0.46/server/core.c:3558

this is being triggered from the same request each time, it appears:

(gdb) print r->the_request
$2 = 0x8f7e408 "GET
/egroupware/index.php?menuaction=infolog.uiinfolog.index&filter=open-today
HTTP/1.1"
Comment 1 Matthew Galgoci 2004-11-16 12:09:55 EST
Ralf, Can you comment on the egroupware code in question?
Comment 2 Ralf Becker 2004-11-21 18:23:15 EST
Not sure what you want to know about the code.

It's generates InfoLog's main listing:
- it fetches some data from the db
- pases it together with a template to the eTemplate class
- which displays it

The problem is the bug does not happen all the time, then we could add
some debug code to see in which parts it fails.

I'm not an expert on php's internal flow: Is the above call-stack what
usualy happens when php shuts down at the end of a script?

Ralf
Comment 3 Joe Orton 2005-09-14 10:01:28 EDT
Did you find a workaround for this Matt or is it still an issue?
Comment 4 Ralf Becker 2005-09-18 06:01:15 EDT
Hi Joe,

as far as I know, this does not longer happen.

I dont know what has been changed, I only know it was not on the eGroupWare side.

Ralf
Comment 6 RHEL Product and Program Management 2007-10-19 15:14:05 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.